aboutsummaryrefslogtreecommitdiffstats
path: root/community/libcue/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 12:28:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 13:59:38 -0300
commited962b4edca29195bf1257ae4c4e4a52fc10caf5 (patch)
tree6bf3bbf8d65c9e860fb50a37a9953ec7f3205be7 /community/libcue/APKBUILD
parentbf14e7dec82bbab058f7cd400f6f71dfafcc1c07 (diff)
downloadaports-ed962b4edca29195bf1257ae4c4e4a52fc10caf5.tar.bz2
aports-ed962b4edca29195bf1257ae4c4e4a52fc10caf5.tar.xz
community/libcue: modernize
Diffstat (limited to 'community/libcue/APKBUILD')
-rw-r--r--community/libcue/APKBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/community/libcue/APKBUILD b/community/libcue/APKBUILD
index f734d309b9..514e659adf 100644
--- a/community/libcue/APKBUILD
+++ b/community/libcue/APKBUILD
@@ -1,35 +1,32 @@
-# Contributor:
-# Maintainer:
+# Contributor:
+# Maintainer:
pkgname=libcue
pkgver=2.2.1
-pkgrel=0
+pkgrel=1
pkgdesc="Library for parsing CUE sheet files"
url="https://github.com/lipnitsk/libcue"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
arch="all"
-depends=
makedepends="cmake bison flex"
-install=
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/lipnitsk/libcue/archive/v$pkgver.tar.gz"
build() {
- cd "$builddir"
- cmake \
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=true .
- make
+ -DBUILD_SHARED_LIBS=true
+ make -C build
}
check() {
- cd "$builddir"
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}
sha512sums="32e476cb09ed2cb2d64aaba1342fb91e77e448391b493a3a794a8d2a6723a0e6097a90b11c6ad82998cb7f270f4f18c2578d7b8575f6929c2a35502e09ebc964 libcue-2.2.1.tar.gz"