aboutsummaryrefslogtreecommitdiffstats
path: root/community/libdazzle/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 00:20:25 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 00:36:16 +0200
commite9681427326d2bdc548c7eda0de5b428009f0884 (patch)
treecba6979d011ea8698dcf65094668bf122f934ef9 /community/libdazzle/APKBUILD
parent90d106253156d388e144f11cd2c0294332a0d378 (diff)
downloadaports-e9681427326d2bdc548c7eda0de5b428009f0884.tar.bz2
aports-e9681427326d2bdc548c7eda0de5b428009f0884.tar.xz
community/libdazzle: move from testing
Diffstat (limited to 'community/libdazzle/APKBUILD')
-rw-r--r--community/libdazzle/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/libdazzle/APKBUILD b/community/libdazzle/APKBUILD
new file mode 100644
index 0000000000..ebe91838d3
--- /dev/null
+++ b/community/libdazzle/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=libdazzle
+pkgver=3.34.0
+pkgrel=0
+pkgdesc="Library to delight your users with fancy features"
+url="https://gitlab.gnome.org/GNOME/libdazzle"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="gtk+3.0-dev vala gobject-introspection-dev gtk-doc meson"
+checkdepends="xvfb-run"
+subpackages="$pkgname-dev"
+source="https://download.gnome.org/sources/libdazzle/${pkgver%.*}/libdazzle-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --buildtype=release \
+ -Denable_gtk_doc=false \
+ . output
+ ninja -C output
+}
+
+check() {
+ xvfb-run ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="2b8840a4537d314773ed4e08c1addd96598eced81b01e0dd2c5c4851f830355fb091193419c7d522397a0cff092202ad4aa1737ba07c78f65f9f69801cba8169 libdazzle-3.34.0.tar.xz"