aboutsummaryrefslogtreecommitdiffstats
path: root/community/libetonyek
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 08:26:56 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-05-18 12:52:04 +0000
commit9d0b9d8b85f463ce5858cb334789ef040f2a7fc0 (patch)
treeb76b8e8e4eb56abd8df8d6de346dc80fa07ea4ef /community/libetonyek
parenta1b600e3e776fbcbeb1253fbdc404d2a082f46f2 (diff)
downloadaports-9d0b9d8b85f463ce5858cb334789ef040f2a7fc0.tar.bz2
aports-9d0b9d8b85f463ce5858cb334789ef040f2a7fc0.tar.xz
community/libetonyek: moved from main
Diffstat (limited to 'community/libetonyek')
-rw-r--r--community/libetonyek/APKBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/community/libetonyek/APKBUILD b/community/libetonyek/APKBUILD
new file mode 100644
index 0000000000..4fdd62298e
--- /dev/null
+++ b/community/libetonyek/APKBUILD
@@ -0,0 +1,56 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=libetonyek
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="Import filter and tools for Apple Keynote presentations"
+url="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
+arch="all"
+license="MPL2"
+depends=""
+depends_dev="glm-dev boost-dev librevenge-dev libxml2-dev zlib-dev"
+makedepends="$depends_dev gperf doxygen mdds-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-werror \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+tools() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="8a2c7de34b5c02f4a75ba086bc5af57b libetonyek-0.1.3.tar.xz"
+sha256sums="fe12276a62bd5f5ca4f5bfbd4938a74d097084e1f9fe173e521f63203f56f055 libetonyek-0.1.3.tar.xz"
+sha512sums="912cb94e6cd63a162a8831368f953c4e6fb14b582a13a7ce93c0bcbb63b688fcbe4733dbb883d6a9faee2011ca5e888d00adda075c2a58d00858770ed68d6844 libetonyek-0.1.3.tar.xz"