aboutsummaryrefslogtreecommitdiffstats
path: root/community/libevhtp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-10 13:38:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-10 13:38:42 +0000
commitedcd2fc03278ac8ff6c3cb1c98e33805ada8ce93 (patch)
treef17b6ac796d464a759e5ddb6e5eb3a64327d4c4f /community/libevhtp
parentbf4cf79b81f0ddb0c7c95b8d791ec48a2698f692 (diff)
downloadaports-edcd2fc03278ac8ff6c3cb1c98e33805ada8ce93.tar.bz2
aports-edcd2fc03278ac8ff6c3cb1c98e33805ada8ce93.tar.xz
community/seafile (and deps): move from main
Diffstat (limited to 'community/libevhtp')
-rw-r--r--community/libevhtp/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/libevhtp/APKBUILD b/community/libevhtp/APKBUILD
new file mode 100644
index 0000000000..12e15c0467
--- /dev/null
+++ b/community/libevhtp/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libevhtp
+pkgver=1.2.11
+pkgrel=0
+pkgdesc="Flexible replacement for libevent's httpd API"
+url="https://github.com/ellzey/libevhtp/"
+arch="all"
+license="BSD"
+makedepends="cmake libevent-dev openssl-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ellzey/libevhtp/archive/${pkgver}.tar.gz"
+subpackages="$pkgname-dev"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ cmake -DCUSTOM_BINDIR=/usr/bin \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCUSTOM_DOCDIR="/usr/share/doc/${pkgname}" \
+ -DCUSTOM_SHAREDIR="/usr/share/${pkgname}" \
+ -DEVHTP_BUILD_SHARED=ON \
+
+ .
+ make || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="d0af057bc23f15ae5959088b86ad6352 libevhtp-1.2.11.tar.gz"
+sha256sums="0e60ef0b75c9e0351d18e015c9a688a70d9c66d2ca3f6a44a7da7153e11e067d libevhtp-1.2.11.tar.gz"
+sha512sums="849102c9e5ec54f4bbe4b4106e72ddd0864c8636bdd1f821e70d6dc4dc0b8b0039257e67d597199161187d522ff65dc826862adfc7c60e755a1ffa95fcd2ac44 libevhtp-1.2.11.tar.gz"