aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgdata
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-04-12 15:40:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-04-12 15:40:33 +0000
commit0ea20c954b11b5e2bc773a32e967ebbe09fe3ed0 (patch)
tree6d04a3b1fe9da47424f5618f8892abf24a7a09bc /community/libgdata
parent846825bea177cf712a9c73eeebb383901c87d0c0 (diff)
downloadaports-0ea20c954b11b5e2bc773a32e967ebbe09fe3ed0.tar.bz2
aports-0ea20c954b11b5e2bc773a32e967ebbe09fe3ed0.tar.xz
community/libgdata: move from testing
needed by shotwell
Diffstat (limited to 'community/libgdata')
-rw-r--r--community/libgdata/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/libgdata/APKBUILD b/community/libgdata/APKBUILD
new file mode 100644
index 0000000000..c43c42e24f
--- /dev/null
+++ b/community/libgdata/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=libgdata
+pkgver=0.17.6
+pkgrel=0
+pkgdesc="access library for gdata"
+url="http://live.gnome.org/libgdata"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="libsoup-dev json-glib-dev liboauth-dev"
+makedepends="$depends_dev intltool uhttpmock-dev glib-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/libgdata/${pkgver%.*}/libgdata-${pkgver}.tar.xz"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ DATADIRNAME=share ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-gnome \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="7f64e6091c734e722111fde1794b2e10 libgdata-0.17.6.tar.xz"
+sha256sums="8b6a3ff1db23bd9e5ebbcc958b29b769a898f892eed4798222d562ba69df30b0 libgdata-0.17.6.tar.xz"
+sha512sums="940e5155b0cda0604e09efcdeabbfcb54ebe97b40d1086823802d3a49fdb7fcfc97749ae218c15d30e4981d01e34d1ae3bed01c1ee9a283063761527a9405731 libgdata-0.17.6.tar.xz"