aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgdata
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-11 12:31:58 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-06-02 15:18:54 +0000
commitb4d01daa0a5f345aeb990551278b0efd89e94d8e (patch)
tree95df2b247be81f338a873020f636e4dfc4fa3b45 /community/libgdata
parent13129b99661d439847296d2609e361ccda81e0b4 (diff)
downloadaports-b4d01daa0a5f345aeb990551278b0efd89e94d8e.tar.bz2
aports-b4d01daa0a5f345aeb990551278b0efd89e94d8e.tar.xz
community/libgdata: enable GOA and GNOME integration, required for gvfs
* Modernize APKBUILD * Adopt package * Fix URL&License Closes GH-7597
Diffstat (limited to 'community/libgdata')
-rw-r--r--community/libgdata/APKBUILD51
-rw-r--r--community/libgdata/only-ipv4-tests.patch13
2 files changed, 47 insertions, 17 deletions
diff --git a/community/libgdata/APKBUILD b/community/libgdata/APKBUILD
index 8b4896f812..7ad4136d15 100644
--- a/community/libgdata/APKBUILD
+++ b/community/libgdata/APKBUILD
@@ -1,36 +1,53 @@
-# Contributor:
-# Maintainer:
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=libgdata
pkgver=0.17.9
-pkgrel=1
+pkgrel=2
pkgdesc="access library for gdata"
-url="http://live.gnome.org/libgdata"
+url="https://wiki.gnome.org/Projects/libgdata"
arch="all"
-license="LGPL"
-makedepends="intltool uhttpmock-dev glib-dev
- libsoup-dev json-glib-dev liboauth-dev"
-checkdepends="gsettings-desktop-schemas"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/libgdata/${pkgver%.*}/libgdata-${pkgver}.tar.xz"
-builddir="${srcdir}/${pkgname}-${pkgver}"
+license="LGPL-2.1-or-later"
+depends="gsettings-desktop-schemas"
+makedepends="intltool uhttpmock-dev glib-dev vala gobject-introspection-dev
+ libsoup-dev json-glib-dev liboauth-dev gnome-online-accounts-dev gcr-dev
+ automake autoconf libtool"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/libgdata/${pkgver%.*}/libgdata-${pkgver}.tar.xz
+ only-ipv4-tests.patch"
+
+prepare() {
+ default_prepare
+
+ # Timeout on armhf
+ case "${DRONE_REPO_OWNER}-${DRONE_RUNNER_PLATFORM}-${CARCH}" in
+ alpinelinux-linux/arm-armhf)
+ sed -i -e '/perf/d' gdata/tests/Makefile.am
+ ;;
+ alpinelinux-*-*)
+ echo "DroneCI: ${DRONE_REPO_OWNER}-${DRONE_RUNNER_PLATFORM}-${CARCH}"
+ ;;
+ esac
+
+ intltoolize --copy --force
+ autoreconf --install --force
+}
build() {
- cd "$builddir"
- DATADIRNAME=share ./configure \
+ ./configure \
--prefix=/usr \
--sysconfdir=/etc \
- --disable-gnome
+ --datadir=/usr/share \
+ --enable-gnome \
+ --enable-goa
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="90289309cbdc4ec6932bf385ddbfcc75c0c2f8b9ca356329298aaa37f6c3db7a16de20e5c947c16c595e43e729a664e4d6d3e2c5a60bb1e463a13d1306f374ce libgdata-0.17.9.tar.xz"
+sha512sums="90289309cbdc4ec6932bf385ddbfcc75c0c2f8b9ca356329298aaa37f6c3db7a16de20e5c947c16c595e43e729a664e4d6d3e2c5a60bb1e463a13d1306f374ce libgdata-0.17.9.tar.xz
+844d5d342e62e6237f48f574b1749c4e4216edc5bfb21bfd799e3ce4f7d88f63bf32b242f99df828bc56fb7fb9e42080ca803bcc404fe6422a8b569df85507e1 only-ipv4-tests.patch"
diff --git a/community/libgdata/only-ipv4-tests.patch b/community/libgdata/only-ipv4-tests.patch
new file mode 100644
index 0000000000..acbb00c1c4
--- /dev/null
+++ b/community/libgdata/only-ipv4-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/gdata/tests/streams.c b/gdata/tests/streams.c
+index 7158754..1763bd9 100644
+--- a/gdata/tests/streams.c
++++ b/gdata/tests/streams.c
+@@ -193,7 +193,7 @@ create_server (SoupServerCallback callback, gpointer user_data, GMainLoop **main
+ g_main_context_push_thread_default (context);
+
+ soup_server_listen_local (server, 0 /* random port */,
+- SOUP_SERVER_LISTEN_HTTPS, &error);
++ SOUP_SERVER_LISTEN_HTTPS | SOUP_SERVER_LISTEN_IPV4_ONLY, &error);
+ g_assert_no_error (error);
+
+ g_main_context_pop_thread_default (context);