aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgnome-keyring
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-13 13:35:53 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-15 09:16:45 +0000
commit26f6d76b3a625e3d7c09ebf3ca1a1826d24df42a (patch)
tree779b43c2c0980c6fff1452b1ce4e06e43b4aa596 /community/libgnome-keyring
parentc3727254887cd7b07e19e7333608f9a5610f6adc (diff)
downloadaports-26f6d76b3a625e3d7c09ebf3ca1a1826d24df42a.tar.bz2
aports-26f6d76b3a625e3d7c09ebf3ca1a1826d24df42a.tar.xz
community/libgnome-keyring: modernize and add check
Diffstat (limited to 'community/libgnome-keyring')
-rw-r--r--community/libgnome-keyring/APKBUILD34
1 files changed, 13 insertions, 21 deletions
diff --git a/community/libgnome-keyring/APKBUILD b/community/libgnome-keyring/APKBUILD
index 25902e676b..e400d839c3 100644
--- a/community/libgnome-keyring/APKBUILD
+++ b/community/libgnome-keyring/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libgnome-keyring
pkgver=3.12.0
-pkgrel=0
+pkgrel=1
pkgdesc="GNOME keyring"
url="http://www.gnome.org"
arch="all"
@@ -26,39 +26,31 @@ depends_dev="gtk+3.0-dev
libxext-dev
libxcb-dev"
makedepends="$depends_dev intltool gobject-introspection-dev"
-install=
subpackages="$pkgname-dev $pkgname-lang"
-source="https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-_builddir="${srcdir}/${pkgname}-${pkgver}"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc \
- || return 1
- make || return 1
+ --sysconfdir=/etc
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
+ cd "$builddir"
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="6696e4f2e9aed4625cdc3af30bd8c238 libgnome-keyring-3.12.0.tar.xz"
-sha256sums="c4c178fbb05f72acc484d22ddb0568f7532c409b0a13e06513ff54b91e947783 libgnome-keyring-3.12.0.tar.xz"
sha512sums="dd1777b6e0dd774feb86dbc72d9f2a85f2143e2772a09c438b84aec468ddc5e7ee5ebd534d24f079e5daf4757f2918d0621e26fb671fde0fcef9c74d30f8b9bd libgnome-keyring-3.12.0.tar.xz"