aboutsummaryrefslogtreecommitdiffstats
path: root/community/libgxps
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /community/libgxps
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'community/libgxps')
-rw-r--r--community/libgxps/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/libgxps/APKBUILD b/community/libgxps/APKBUILD
index 558723405c..f16046e6c2 100644
--- a/community/libgxps/APKBUILD
+++ b/community/libgxps/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Paul Bredbury <brebs@sent.com>
pkgname=libgxps
pkgver=0.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="XPS documents library & conversion utilities"
url="https://wiki.gnome.org/action/show/Projects/libgxps"
arch="all"
@@ -14,7 +14,7 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- meson --prefix=/usr --libdir=lib --buildtype=release build/
+ meson --prefix=/usr --libdir=lib --buildtype=debugoptimized build/
ninja -v -C build/
}