aboutsummaryrefslogtreecommitdiffstats
path: root/community/libhdhomerun
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-02-25 12:22:24 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2016-02-25 12:22:29 +0100
commit521e491695c4ce430cdf03f66d2c2c80e3e39d1c (patch)
treea7c2b7ad8eb005290f02cacc5ff3f22b5c8055f5 /community/libhdhomerun
parentdacff0b394eb656de164164cd80eb8711291961b (diff)
downloadaports-521e491695c4ce430cdf03f66d2c2c80e3e39d1c.tar.bz2
aports-521e491695c4ce430cdf03f66d2c2c80e3e39d1c.tar.xz
community/libhdhomerun: fix srcdir cosmetics and move to community
Diffstat (limited to 'community/libhdhomerun')
-rw-r--r--community/libhdhomerun/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/libhdhomerun/APKBUILD b/community/libhdhomerun/APKBUILD
new file mode 100644
index 0000000000..3edb77497d
--- /dev/null
+++ b/community/libhdhomerun/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Hasse Hagen Johansen <hasse-docker@hagenjohansen.dk>
+# Maintainer: Hasse Hagen Johansen <hasse-docker@hagenjohansen.dk>
+pkgname=libhdhomerun
+pkgver=20150826
+pkgrel=0
+pkgdesc="Library for Silicon Dust HD HomeRun"
+url="http://www.silicondust.com/support/downloads/linux/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-config"
+source="http://download.silicondust.com/hdhomerun/${pkgname}_${pkgver}.tgz"
+
+_builddir="$srcdir/$pkgname"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm444 libhdhomerun.so \
+ "$pkgdir"/usr/lib/libhdhomerun.so || return 1
+ install -D *.h "$pkgdir"/usr/include/libhdhomerun || return 1
+ install -Dm644 lgpl.txt \
+ "$pkgdir"/usr/share/licenses/$pkgname/lgpl.txt || return 1
+}
+
+config() {
+ pkgdesc="$pkgname config utility"
+ cd "$_builddir"
+ install -Dm755 hdhomerun_config \
+ "$subpkgdir"/usr/bin/hdhomerun_config || return 1
+}
+
+md5sums="05f9a9e1fc8f6ec004b399034775cab0 libhdhomerun_20150826.tgz"
+sha256sums="907dfbd1eb82aebd8b09e7c00c21a02433e6baaacf4a4f99aa2511b1d5244baf libhdhomerun_20150826.tgz"
+sha512sums="9b401c1649dc8c32ea9019b732631f9213cb66c43771aa148fa318202fc11739c005c474be6a77a6a7807818b5179f77debb5b2d2411d865cc87bb3d7ab629a6 libhdhomerun_20150826.tgz"