aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmatekbd
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:40 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:47 +0100
commit6b7708f80cba5821ea35a2540fea8c38c26ac299 (patch)
treeb140445577acac3a4c95172bae7c099469247fd2 /community/libmatekbd
parentca20fa8cf8d69415ba0d3d15e2cf40ac021776b8 (diff)
downloadaports-6b7708f80cba5821ea35a2540fea8c38c26ac299.tar.bz2
aports-6b7708f80cba5821ea35a2540fea8c38c26ac299.tar.xz
main/libmatekbd: move to community
Diffstat (limited to 'community/libmatekbd')
-rw-r--r--community/libmatekbd/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/libmatekbd/APKBUILD b/community/libmatekbd/APKBUILD
new file mode 100644
index 0000000000..7b52d3613f
--- /dev/null
+++ b/community/libmatekbd/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=libmatekbd
+pkgver=1.10.0
+pkgrel=0
+pkgdesc="MATE keyboard library"
+url="https://github.com/mate-desktop/libmatekbd"
+arch="all"
+license="GPL2"
+depends="mate-common freetype"
+depends_dev=""
+makedepends="$depends_dev libxklavier-dev libtool intltool gtk+2.0-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="746c5c3c57895f64a3ebfa74a6dc34f3 libmatekbd-1.10.0.tar.xz"
+sha256sums="09d9bb75d784083036e24a29120f5933f0dfdfe59050858dd353fd7572d7d2d1 libmatekbd-1.10.0.tar.xz"
+sha512sums="8f846d7a493d913bdeb578c7b9ed8e0a315907943d44a56a747d1134841a8dde3a6b496b98241a1481bed13c4fd0f40db5496c29334aad4481e8dc35cc916e16 libmatekbd-1.10.0.tar.xz"