aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmcrypt
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-27 07:57:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-29 15:55:32 +0000
commitb43c0f2c41358639994e61387db7edc49c8b0a9e (patch)
treed28a000453f901730f1793d945b3b4fff4c4fa17 /community/libmcrypt
parent3d69d14c425b8ae6bc28d5936cd602c0e5e977ab (diff)
downloadaports-b43c0f2c41358639994e61387db7edc49c8b0a9e.tar.bz2
aports-b43c0f2c41358639994e61387db7edc49c8b0a9e.tar.xz
community/libmcrypt: move from main
Diffstat (limited to 'community/libmcrypt')
-rw-r--r--community/libmcrypt/APKBUILD39
-rw-r--r--community/libmcrypt/fix_enigma.patch21
2 files changed, 60 insertions, 0 deletions
diff --git a/community/libmcrypt/APKBUILD b/community/libmcrypt/APKBUILD
new file mode 100644
index 0000000000..9de9c07fb3
--- /dev/null
+++ b/community/libmcrypt/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=libmcrypt
+pkgver=2.5.8
+pkgrel=8
+pkgdesc="A library which provides a uniform interface to several symmetric encryption algorithms"
+url="http://mcrypt.sourceforge.net/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="libtool"
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://downloads.sourceforge.net/mcrypt/libmcrypt-$pkgver.tar.bz2
+ fix_enigma.patch
+ "
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-posix-threads
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="6c05c42767401d66af67b0922b207d17cdb1c3efdbfdfb5b0c2e651821c48a8a6c6749debfa0206091b8a801f538fabe9f7d95ebc86d82c6b84c8001031d50fe libmcrypt-2.5.8.tar.bz2
+d39ffc4cab1692159a93f9f4f9c8d7386be0135396bae95a06978288d8462241d1d17fbfaffce52dbec065667fb9e21c36b350a1710ccf7620611b4a80d511ab fix_enigma.patch"
diff --git a/community/libmcrypt/fix_enigma.patch b/community/libmcrypt/fix_enigma.patch
new file mode 100644
index 0000000000..bdcff7cfbe
--- /dev/null
+++ b/community/libmcrypt/fix_enigma.patch
@@ -0,0 +1,21 @@
+https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=917203
+
+--- src/modules/algorithms/enigma.h.orig 2002-03-09 21:17:08.000000000 +0100
++++ src/modules/algorithms/enigma.h 2019-04-07 13:54:03.000000000 +0200
+@@ -3,11 +3,11 @@
+ #define MASK 0377
+
+ typedef struct crypt_key {
+- char t1[ROTORSZ];
+- char t2[ROTORSZ];
+- char t3[ROTORSZ];
+- char deck[ROTORSZ];
+- char cbuf[13];
++ signed char t1[ROTORSZ];
++ signed char t2[ROTORSZ];
++ signed char t3[ROTORSZ];
++ signed char deck[ROTORSZ];
++ signed char cbuf[13];
+ int n1, n2, nr1, nr2;
+ } CRYPT_KEY;
+ \ No newline at end of file