aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmms
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-26 22:25:31 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-26 23:33:40 -0300
commit6f6abe97f7b89a1fe7c45438bb24a67e1f5afc47 (patch)
treeb9a0ab5635fc84e767861c37620df960eb64b42d /community/libmms
parent2984ad114ab465cfce4119cbaf7f5796022d179d (diff)
downloadaports-6f6abe97f7b89a1fe7c45438bb24a67e1f5afc47.tar.bz2
aports-6f6abe97f7b89a1fe7c45438bb24a67e1f5afc47.tar.xz
community/libmms: move from main
Diffstat (limited to 'community/libmms')
-rw-r--r--community/libmms/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/libmms/APKBUILD b/community/libmms/APKBUILD
new file mode 100644
index 0000000000..99af248702
--- /dev/null
+++ b/community/libmms/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmms
+pkgver=0.6.4
+pkgrel=1
+pkgdesc="MMS stream protocol library"
+url="https://sourceforge.net/projects/libmms/"
+arch="all"
+options="!check" # No test suite.
+license="LGPL-2.0-or-later"
+makedepends="glib-dev"
+subpackages="$pkgname-dev"
+source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+"
+
+prepare() {
+ cd "$builddir"
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-static
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9771c697515f5232eaeaff79e68fe15e34d8aa38aa5d3d68525216357223f314c544d71b5fe18d79a77682f41b1b5d9fb5e7c3c99d0cba5723d2e3de31faec96 libmms-0.6.4.tar.gz"