aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmspack
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /community/libmspack
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'community/libmspack')
-rw-r--r--community/libmspack/APKBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/community/libmspack/APKBUILD b/community/libmspack/APKBUILD
new file mode 100644
index 0000000000..beb71a8782
--- /dev/null
+++ b/community/libmspack/APKBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libmspack
+pkgver=0.8_alpha
+_ver=${pkgver/_/}
+pkgrel=1
+pkgdesc="Library for Microsoft CAB compression formats"
+url="https://www.cabextract.org.uk/libmspack/"
+arch="all"
+license="LGPL-2.1-only"
+makedepends="$depends_dev"
+subpackages="$pkgname-dev $pkgname-utils"
+source="https://www.cabextract.org.uk/libmspack/libmspack-$_ver.tar.gz"
+
+builddir="$srcdir"/libmspack-$_ver
+
+# secfixes:
+# 0.8_alpha-r0:
+# - CVE-2018-18584
+# - CVE-2018-18585
+# - CVE-2018-18586
+# 0.7.1_alpha-r0:
+# - CVE-2018-14679
+# - CVE-2018-14680
+# - CVE-2018-14681
+# - CVE-2018-14682
+# 0.5_alpha-r1:
+# - CVE-2017-6419
+# - CVE-2017-11423
+
+prepare() {
+ default_prepare
+ sed -i "s/@VERSION@/$pkgver/" libmspack.pc.in
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static
+ # parallel build workaround
+ make libmspack.la libmscabd.la libmschmd.la
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+utils() {
+ pkgdesc="$pkgdesc (utils)"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+sha512sums="d178afc4d2eded204594c81af1c91be17d3be4f1a09829e08c103023aa7badc6b2595e9ec13cc7f77e3262d2cd874ed40ce6da01695c5c839682562740d2bf0a libmspack-0.8alpha.tar.gz"