aboutsummaryrefslogtreecommitdiffstats
path: root/community/libmypaint
diff options
context:
space:
mode:
authorSascha Paunovic <azarus@posteo.net>2018-06-03 17:26:02 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-07-19 11:53:13 +0300
commitb141deb61dfbb41ff2ecfd4d6c560fa3d108ef69 (patch)
tree8dc6795503173eab17cf15187c1ccac05d432615 /community/libmypaint
parentb3db8b80511d4da70e7ab168959553db46a8c94e (diff)
downloadaports-b141deb61dfbb41ff2ecfd4d6c560fa3d108ef69.tar.bz2
aports-b141deb61dfbb41ff2ecfd4d6c560fa3d108ef69.tar.xz
community/libmypaint: new aport
Is a dependency for the new GIMP 2.10.2.
Diffstat (limited to 'community/libmypaint')
-rw-r--r--community/libmypaint/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/libmypaint/APKBUILD b/community/libmypaint/APKBUILD
new file mode 100644
index 0000000000..dcc38d395c
--- /dev/null
+++ b/community/libmypaint/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Sascha Paunovic <azarus@posteo.net>
+# Maintainer: Sascha Paunovic <azarus@posteo.net>
+pkgname=libmypaint
+pkgver=1.3.0
+pkgrel=0
+pkgdesc="library for making brushstrokes"
+url="http://mypaint.org/"
+arch="all"
+license="ISC"
+makedepends="glib-dev json-c-dev gobject-introspection-dev intltool"
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://github.com/mypaint/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/"$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="553eeb3439ffd0c013e33254a16334242583b8bab76d1a3e937f3ed1d7e05a832c6eb26acd7220dce20c6a7d997c32afe828202ce48e25a5fe57b67efd853fcf libmypaint-1.3.0.tar.xz"