aboutsummaryrefslogtreecommitdiffstats
path: root/community/libndp
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-05-05 06:18:07 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-05-05 06:19:01 +0000
commitd37a726931a4432501d94ae5eac636d7229f88a2 (patch)
treef21dd6e4b1e15d8a3030629790ce4dbe1ded2227 /community/libndp
parent3f38666f50687bc874293b95d2c7c58cd3dca053 (diff)
downloadaports-d37a726931a4432501d94ae5eac636d7229f88a2.tar.bz2
aports-d37a726931a4432501d94ae5eac636d7229f88a2.tar.xz
community/libndp: upgrade to 1.6
Update source, add check(), modernize APKBUILD
Diffstat (limited to 'community/libndp')
-rw-r--r--community/libndp/0001-remove-bash-dependency.patch22
-rw-r--r--community/libndp/APKBUILD40
-rw-r--r--community/libndp/fix-fd_set.patch32
3 files changed, 63 insertions, 31 deletions
diff --git a/community/libndp/0001-remove-bash-dependency.patch b/community/libndp/0001-remove-bash-dependency.patch
new file mode 100644
index 0000000000..5625f7e3c0
--- /dev/null
+++ b/community/libndp/0001-remove-bash-dependency.patch
@@ -0,0 +1,22 @@
+From 809c779513531debbb00369e09b882296abdbc73 Mon Sep 17 00:00:00 2001
+From: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Fri, 5 May 2017 06:11:19 +0000
+Subject: [PATCH] remove bash dependency
+
+---
+ autogen.sh | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/autogen.sh b/autogen.sh
+index 665de9c..e5b866d 100755
+--- a/autogen.sh
++++ b/autogen.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ autoreconf --force --install -I m4
+ rm -Rf autom4te.cache;
+--
+2.12.2
+
diff --git a/community/libndp/APKBUILD b/community/libndp/APKBUILD
index 556ffb47ad..33390cfa7e 100644
--- a/community/libndp/APKBUILD
+++ b/community/libndp/APKBUILD
@@ -1,34 +1,28 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libndp
-pkgver=1.4
+pkgver=1.6
pkgrel=0
pkgdesc="Library for IPv6 Neighbor Discovery Protocol"
url="http://libndp.org"
arch="all"
license="GPL2.1"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
+makedepends="autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://libndp.org/files/$pkgname-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/jpirko/libndp/archive/v$pkgver.tar.gz
+ 0001-remove-bash-dependency.patch
fix-fd_set.patch
"
+builddir="$srcdir"/$pkgname-$pkgver
-_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ default_prepare
+ ./autogen.sh
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,14 +36,16 @@ build() {
make || return 1
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="52c708d4b8729ae6e3781b3737a85e16 libndp-1.4.tar.gz
-7b1e885680e9677de2f25707850db7dd fix-fd_set.patch"
-sha256sums="3a0be247ec024bd72fe5b40ea9491519c4023c7faf078311196fab817b2fd55f libndp-1.4.tar.gz
-401a6d2601790f136e9c7b51b49003c3994df93136c6acdb289ce377d7068942 fix-fd_set.patch"
-sha512sums="a84d4d6672bf83bcf865eef8986e7bbcc49587686c5085a5ce5f346791223ede0e60db3b990055afc4f0005182aa1b5546c459306d2955f95d00ffb68bd58766 libndp-1.4.tar.gz
-291503b1a9b21ae3e75d0048fadaa0bace989c6091ddb7238ed7920d4daa968bbd66608432de341fa2cde33d440dcd1b679bc590c7b8d91a68363f5469abc92b fix-fd_set.patch"
+sha512sums="9ecaf36656cea8b71b2864eda7e5e2d106c4e861fc7506be9ce309aabee2dfcd695c55f65ae1db4afc1d44cf20b30e1ebf84dbb15d6b39bff5d3833fed57ae19 libndp-1.6.tar.gz
+e0cdeb09b757c8b8ed199ae9178dedcbb64769fee775be73f6c704fcb7fd749a91fda6c85b11f6ffcc010cef05a5ecc1d5b334374fa5056ab1cfae170e8afd6a 0001-remove-bash-dependency.patch
+16660eaad5159056d2872f8a92296e2473ac2ef8cf663d0bb40b8bd95c2c9cdf74b94642e22abaddc58b1f8a74e8ab39a6ef6356d8226e9dca0e603440bfaee9 fix-fd_set.patch"
diff --git a/community/libndp/fix-fd_set.patch b/community/libndp/fix-fd_set.patch
index 7797418c1a..c0b72d3d56 100644
--- a/community/libndp/fix-fd_set.patch
+++ b/community/libndp/fix-fd_set.patch
@@ -1,10 +1,24 @@
---- libndp-1.4/utils/ndptool.c
-+++ libndp-1.4/utils/ndptool.c.new
-@@ -22,6 +22,7 @@
- #include <unistd.h>
- #include <string.h>
- #include <signal.h>
+From 60a0c678e1c1fce9a979cc18d66f25853e965181 Mon Sep 17 00:00:00 2001
+From: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Fri, 5 May 2017 06:14:22 +0000
+Subject: [PATCH] fix includes
+
+---
+ utils/ndptool.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/utils/ndptool.c b/utils/ndptool.c
+index 1d96f4c..96479fa 100644
+--- a/utils/ndptool.c
++++ b/utils/ndptool.c
+@@ -28,6 +28,7 @@
+ #include <arpa/inet.h>
+ #include <errno.h>
+ #include <ndp.h>
+#include <sys/select.h>
- #include <sys/signalfd.h>
- #include <getopt.h>
- #include <net/if.h>
+
+ enum verbosity_level {
+ VERB1,
+--
+2.12.2
+