aboutsummaryrefslogtreecommitdiffstats
path: root/community/liboping
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-26 23:06:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-26 23:33:41 -0300
commitbb2a96ca3b0eaaf37e2ec8f2c4074880a4f01b45 (patch)
treec3af51cefd7210aa5f9906f97ed3b15b56dd5c52 /community/liboping
parentc1846533a801fb147bb1798d7ffc7c2c6390435c (diff)
downloadaports-bb2a96ca3b0eaaf37e2ec8f2c4074880a4f01b45.tar.bz2
aports-bb2a96ca3b0eaaf37e2ec8f2c4074880a4f01b45.tar.xz
community/liboping: move from main
Diffstat (limited to 'community/liboping')
-rw-r--r--community/liboping/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/liboping/APKBUILD b/community/liboping/APKBUILD
new file mode 100644
index 0000000000..ae3504ffc6
--- /dev/null
+++ b/community/liboping/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Harry
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liboping
+pkgver=1.10.0
+pkgrel=0
+pkgdesc="A C library to generate ICMP echo requests"
+url="http://verplant.org/liboping/"
+arch="all"
+license="LGPL-2.0-or-later"
+depends=""
+makedepends="ncurses-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://verplant.org/liboping/files/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --without-perl-bindings \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+sha512sums="f1e9984cf0c1df89b29f7bc657c19a5439019db7643680744d8f353664b6a53070581f40b51e72f896c7df88799c6868257f6308e1a9d84b4d2a0666491214d8 liboping-1.10.0.tar.bz2"