aboutsummaryrefslogtreecommitdiffstats
path: root/community/libpeas/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-10 23:06:14 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 09:22:34 -0300
commite4f25c5c21f81c08660392c6d5222ba5521f5a3a (patch)
tree04d626444aacdd92b417697fde0ed375688adbaf /community/libpeas/APKBUILD
parent40b2a4ce2dade1d0dc452f5a44fa00ebe783aa77 (diff)
downloadaports-e4f25c5c21f81c08660392c6d5222ba5521f5a3a.tar.bz2
aports-e4f25c5c21f81c08660392c6d5222ba5521f5a3a.tar.xz
community/libpeas: upgrade to 1.24.0
Diffstat (limited to 'community/libpeas/APKBUILD')
-rw-r--r--community/libpeas/APKBUILD39
1 files changed, 21 insertions, 18 deletions
diff --git a/community/libpeas/APKBUILD b/community/libpeas/APKBUILD
index bf8426c925..81aad15b3d 100644
--- a/community/libpeas/APKBUILD
+++ b/community/libpeas/APKBUILD
@@ -1,33 +1,36 @@
-# Contributor:
-# Maintainer:
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=libpeas
-pkgver=1.22.0
-pkgrel=1
+pkgver=1.24.0
+pkgrel=0
pkgdesc="GObject-based plugin system"
url="https://wiki.gnome.org/Projects/Libpeas"
arch="all"
-license="LGPL"
-makedepends="$depends_dev glib-dev gobject-introspection-dev intltool gtk+3.0-dev py-gobject3-dev python3-dev"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-python3:py3"
-source="https://download.gnome.org/sources/libpeas/1.22/libpeas-$pkgver.tar.xz"
-builddir="$srcdir/$pkgname-$pkgver"
+license="LGPL-2.1-or-later"
+makedepends="glib-dev gobject-introspection-dev intltool gtk+3.0-dev py-gobject3-dev python3-dev meson vala glade-dev"
+checkdepends="py3-gobject3 xvfb-run"
+subpackages="$pkgname-dev $pkgname-python3:py3 $pkgname-lang"
+source="https://download.gnome.org/sources/libpeas/${pkgver%.*}/libpeas-$pkgver.tar.xz"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --disable-python2
- make
+ --buildtype=release \
+ -Dvapi=true \
+ -Ddemos=false \
+ . output
+ ninja -C output
+}
+
+check() {
+ xvfb-run meson test -C output -t 10
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
py3() {
@@ -36,4 +39,4 @@ py3() {
mv "$pkgdir"/usr/lib/libpeas-1.0/loaders/libpython3loader.* "$subpkgdir"/usr/lib/libpeas-1.0/loaders/
}
-sha512sums="9c1da1d4b5688c0f4d0647f3519dbfbed94c8921091057aaef0e41bf5ed3f8faf04a49ce9e4eea3fd7bf4ac4dfa1727d76a5f6dae2a4f52228d4c8c74b420c91 libpeas-1.22.0.tar.xz"
+sha512sums="b4baa03ded9d787e7a1ee2be943617f5c84564bf299699934c47ded6c60ff62a7f27ab2594cd0ffba2d8979d8b72113d1b5e910eebd80305f3aa538db0d45314 libpeas-1.24.0.tar.xz"