aboutsummaryrefslogtreecommitdiffstats
path: root/community/libreswan
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-11-12 09:39:57 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-11-12 09:39:57 +0200
commit78b96c7dc8163c675a9bc9c76a8b4cf354c1deec (patch)
tree758af34791909c06891e0decde517c5c9f1ba80c /community/libreswan
parent39fbd1698bce3af6bab5cdf7420b36ca2a76b3f1 (diff)
downloadaports-78b96c7dc8163c675a9bc9c76a8b4cf354c1deec.tar.bz2
aports-78b96c7dc8163c675a9bc9c76a8b4cf354c1deec.tar.xz
community/libreswan: fix inclusion of limits.h
Diffstat (limited to 'community/libreswan')
-rw-r--r--community/libreswan/APKBUILD3
-rw-r--r--community/libreswan/fix-includes.patch11
2 files changed, 14 insertions, 0 deletions
diff --git a/community/libreswan/APKBUILD b/community/libreswan/APKBUILD
index 1265b4deea..53d4046083 100644
--- a/community/libreswan/APKBUILD
+++ b/community/libreswan/APKBUILD
@@ -15,6 +15,8 @@ makedepends="bison flex coreutils bash xmlto
"
subpackages="$pkgname-doc"
source="https://download.libreswan.org/libreswan-$pkgver.tar.gz
+ fix-includes.patch
+
Makefile.inc.local"
builddir="$srcdir"/$pkgname-$pkgver
@@ -42,4 +44,5 @@ package() {
install
}
sha512sums="b92ecfd08b9d19dc801032176eff3dd07f625223d4f0dd07ff10f639644573430a55f7aebfcc8b9d2424e194ca9d06b17ad5a13dad5dc6f659d19bc5d32520f5 libreswan-3.27.tar.gz
+82abffaa5c4c3c427764edc2b89151088a143c945ae1d755e1d929365b3da22ffa4a33ff7555b98072e192b9e096716696319b133aa02495b958f3cd3c9da2aa fix-includes.patch
8c80e5dc8b1b9ac2cd9c3441da2a4253d23328a065655d85f7958ec0678bd42fc74b418524a4787075872c0f545e8fb0394ff168cd25d1dc49010248155ddaef Makefile.inc.local"
diff --git a/community/libreswan/fix-includes.patch b/community/libreswan/fix-includes.patch
new file mode 100644
index 0000000000..57ed0e563e
--- /dev/null
+++ b/community/libreswan/fix-includes.patch
@@ -0,0 +1,11 @@
+diff -ru libreswan-3.27.orig/programs/pluto/connections.c libreswan-3.27/programs/pluto/connections.c
+--- libreswan-3.27.orig/programs/pluto/connections.c 2018-10-08 05:52:09.000000000 +0300
++++ libreswan-3.27/programs/pluto/connections.c 2018-11-12 09:38:40.643062668 +0200
+@@ -41,6 +41,7 @@
+ #include <arpa/inet.h>
+ #include <resolv.h>
+ #include <errno.h>
++#include <limits.h>
+
+ #include <libreswan.h>
+ #include "libreswan/pfkeyv2.h"