aboutsummaryrefslogtreecommitdiffstats
path: root/community/libselinux/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 22:02:29 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-12-16 22:02:29 +0000
commitc3e685320315cf6d88cccaef50b6f669e6483bde (patch)
tree266af5d8744901feb19ba66137b145b27f116e09 /community/libselinux/APKBUILD
parent8748c10f3feda5ab036620a064826b6242e90d89 (diff)
downloadaports-c3e685320315cf6d88cccaef50b6f669e6483bde.tar.bz2
aports-c3e685320315cf6d88cccaef50b6f669e6483bde.tar.xz
community/libselinux: upgrade to 2.8
Diffstat (limited to 'community/libselinux/APKBUILD')
-rw-r--r--community/libselinux/APKBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/community/libselinux/APKBUILD b/community/libselinux/APKBUILD
index 6e70975b29..baffe4dbfd 100644
--- a/community/libselinux/APKBUILD
+++ b/community/libselinux/APKBUILD
@@ -1,30 +1,28 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libselinux
-pkgver=2.6
-pkgrel=1
+pkgver=2.8
+pkgrel=0
pkgdesc="SELinux library and simple utilities"
url="https://github.com/SELinuxProject/selinux/wiki"
arch="all"
license="Public-Domain"
-depends=""
-depends_dev=""
# we need coreutils for ln --relative
-makedepends="$depends_dev pcre-dev linux-headers libsepol-dev fts-dev coreutils"
+makedepends="pcre-dev linux-headers libsepol-dev fts-dev coreutils"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
-source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/libselinux-$pkgver.tar.gz
+source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/libselinux-$pkgver.tar.gz
"
builddir="$srcdir/libselinux-$pkgver"
build() {
cd "$builddir"
- make PCRE_LDFLAGS="-lpcre -lfts" || return 1
+ make PCRE_LDLIBS="-lpcre -lfts"
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
utils() {
@@ -33,4 +31,4 @@ utils() {
mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
}
-sha512sums="906e1bf98c669862ab4f4e883d511db8d739a5763dc857c9405ad3cc6c70766a482853d07134698a1a98257a8632cc756d0549a7640c2915d051714f502ff14b libselinux-2.6.tar.gz"
+sha512sums="2f15d08888fbef9b0cf7bf01893b513edc6738974e2d0eab7e3f79cef9be79cf966742b0d2693b5d2ec7defddb5f4d6c6f6280be9d4158ed41f7a18d50b9f019 libselinux-2.8.tar.gz"