aboutsummaryrefslogtreecommitdiffstats
path: root/community/libsexy/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-16 02:26:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-23 12:07:30 -0300
commit41ab224df12b8487004a1522b4f671680c082954 (patch)
tree9ebbc4ea5d1cfb82757ca1fd862b67e444a712a2 /community/libsexy/APKBUILD
parent1f40937c55d742c7ae05db34c966c3dd2d6595e7 (diff)
downloadaports-41ab224df12b8487004a1522b4f671680c082954.tar.bz2
aports-41ab224df12b8487004a1522b4f671680c082954.tar.xz
community/*: move lots of stuff from main and modernize
Diffstat (limited to 'community/libsexy/APKBUILD')
-rw-r--r--community/libsexy/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/libsexy/APKBUILD b/community/libsexy/APKBUILD
new file mode 100644
index 0000000000..7dfad94e5b
--- /dev/null
+++ b/community/libsexy/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsexy
+pkgver=0.1.11
+pkgrel=9
+pkgdesc="Doing naughty things to good widgets."
+url="https://blog.chipx86.com/tag/libsexy/"
+arch="all"
+options="!check" # Tests require manual intervention and X11 display.
+license="LGPL-2.0-or-later"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="gtk+2.0-dev libxml2-dev iso-codes-dev"
+source="http://releases.chipx86.com/libsexy/libsexy/libsexy-$pkgver.tar.gz"
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib/libsexy.a
+}
+
+sha512sums="12ab0d2925b7a025116b8b03d8af3ed471cb60c0225b33d3a312e35acef95afb0fc265de135354883865fbe2338ca3b2d9356b401aa3bce4b532ec50a32067ca libsexy-0.1.11.tar.gz"