aboutsummaryrefslogtreecommitdiffstats
path: root/community/libteam
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-08-18 20:46:53 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-21 22:24:04 +0200
commit5c9f3ca3e307be53b45beeed2ce1626f38008625 (patch)
tree919836fe454e953f46685adf8228b0401280d4b6 /community/libteam
parent6a00a953ba02bab6440a2c784e7db37c6eaeace1 (diff)
downloadaports-5c9f3ca3e307be53b45beeed2ce1626f38008625.tar.bz2
aports-5c9f3ca3e307be53b45beeed2ce1626f38008625.tar.xz
testing/[various]: move to community
albatross-themes apk-post-messages autossh bitcoin btrbk entr ffmpegthumbnailer firejail firetools fwsnort gnome-colors imapsync inetutils-syslogd inotify-tools-inc isync junit ktsuss letsencrypt-nosudo libmbim libndp libqmi libteam mini-sendmail modemmanager namecoin networkmanager nginx-naxsi numix-themes nxapi opencl-headers opencl-icd-loader opus-tools perl-authen-ntlm perl-bit-vector perl-data-uniqid perl-file-copy-recursive perl-getopt-argvfile perl-io-tee perl-iptables-chainmgr perl-iptables-parse perl-module-scandeps perl-par-dist perl-par-packer perl-par perl-uri-escape psad py-crcmod py-graphviz py-lz4 py-opencl py-opengl-accelerate runit secpwgen secure-delete socklog spacefm tinyssh udevil virt-viewer virtualbricks whois wrk xpra zram-init
Diffstat (limited to 'community/libteam')
-rw-r--r--community/libteam/APKBUILD70
-rw-r--r--community/libteam/fix-fd_set.patch10
-rw-r--r--community/libteam/memcpy-memset-implicit-declaration.patch10
3 files changed, 90 insertions, 0 deletions
diff --git a/community/libteam/APKBUILD b/community/libteam/APKBUILD
new file mode 100644
index 0000000000..1fe5441751
--- /dev/null
+++ b/community/libteam/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+pkgname=libteam
+pkgver=1.23
+pkgrel=0
+pkgdesc="Library for controlling team network device"
+url="http://libteam.org"
+arch="all"
+license="LGPL2.1"
+depends_dev=""
+makedepends="$depends_dev autoconf automake libtool libnl3-dev libdaemon-dev jansson-dev dbus-dev
+ linux-headers bsd-compat-headers doxygen swig python-dev python3-dev"
+subpackages="$pkgname-dev $pkgname-doc py-$pkgname:py"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jpirko/$pkgname/archive/v$pkgver.tar.gz
+ fix-fd_set.patch
+ memcpy-memset-implicit-declaration.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+py() {
+ pkgdesc="Python 2/3 Bindings for libteam"
+ mkdir -p "$subpkgdir"
+ cd "$_builddir"
+ cp -ar binding/python binding/python3 || return 1
+ cd binding/python
+ python ./setup.py build || return 1
+ cd ../python3
+ python3 ./setup.py build || return 1
+ cd binding/python
+ python ./setup.py install --root "$subpkgdir" -O1 || return 1
+ cd ../python3
+ python3 ./setup.py install --root "$subpkgdir" -O1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="f80451570e68a85983de41b0d6dcdd49 libteam-1.23.tar.gz
+ea78f0a9b84eb87747ddfbcfa582a122 fix-fd_set.patch
+fb6662bced494fd24a107e3f7f7dc5e8 memcpy-memset-implicit-declaration.patch"
+sha256sums="b9ed23da5c1a9e6bdd77aee345cce3898312fddaeeb5754dfe29a58610802a78 libteam-1.23.tar.gz
+43bff56cfd3d293ecae58b3a77e55e7a740ddcf188d6516097fbd93b13a82ac8 fix-fd_set.patch
+a2982cbd9bce4367d1a6e20bfedcc24cab452538e2e0ec1af0d8a3515cf21077 memcpy-memset-implicit-declaration.patch"
+sha512sums="f78ceca4606b93e75fafdd97aa3cc44153fc42d31209f216c3da9c71abf38a2e4a690c71b8631ae09e02d7285d6bbd8292983fdc69eb921b0537a75558bc89f5 libteam-1.23.tar.gz
+83f8dd77cfed0f815bc0cb2aa4af25883a02567dbb35b59016d7f3a30f162e63155996d21216424f0ea4efa8e92f8f9526a018a892533c3c7dd7c7ba12b46a44 fix-fd_set.patch
+1279c164960b6215e9bb9f3ee161ef9ac6a38b8066d4a1031996b8067031b9b19404681ebecf3492a26b1215ec2eaaddecae3370ec25e2593dc3ca7dc5f8ead7 memcpy-memset-implicit-declaration.patch"
diff --git a/community/libteam/fix-fd_set.patch b/community/libteam/fix-fd_set.patch
new file mode 100644
index 0000000000..b019ff321b
--- /dev/null
+++ b/community/libteam/fix-fd_set.patch
@@ -0,0 +1,10 @@
+--- libteam-1.17/utils/teamnl.c
++++ libteam-1.17/utils/teamnl.c.new
+@@ -23,6 +23,7 @@
+ #include <string.h>
+ #include <getopt.h>
+ #include <errno.h>
++#include <sys/select.h>
+ #include <sys/signalfd.h>
+ #include <signal.h>
+ #include <unistd.h>
diff --git a/community/libteam/memcpy-memset-implicit-declaration.patch b/community/libteam/memcpy-memset-implicit-declaration.patch
new file mode 100644
index 0000000000..84b1a99b8e
--- /dev/null
+++ b/community/libteam/memcpy-memset-implicit-declaration.patch
@@ -0,0 +1,10 @@
+--- libteam-1.17/teamd/teamd_phys_port_check.c
++++ libteam-1.17/teamd/teamd_phys_port_check.c.new
+@@ -17,6 +17,7 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ */
+
++#include <string.h>
+ #include <stdio.h>
+ #include <errno.h>
+ #include <sys/types.h>