aboutsummaryrefslogtreecommitdiffstats
path: root/community/libteam
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2016-08-31 18:58:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-09-01 13:19:36 +0000
commit9ea56d296dd6b21bc650e039a233bd5b17604011 (patch)
treee0c49628d18ea0fd6925520728d7e50bd697e7aa /community/libteam
parent189a0f8160488973087386014fe4e1033e8d25ef (diff)
downloadaports-9ea56d296dd6b21bc650e039a233bd5b17604011.tar.bz2
aports-9ea56d296dd6b21bc650e039a233bd5b17604011.tar.xz
community/libteam: update to 1.26
Diffstat (limited to 'community/libteam')
-rw-r--r--community/libteam/APKBUILD18
-rw-r--r--community/libteam/fix-redefinition-struct-ethhdr.patch51
2 files changed, 62 insertions, 7 deletions
diff --git a/community/libteam/APKBUILD b/community/libteam/APKBUILD
index 1fe5441751..9bad8d2936 100644
--- a/community/libteam/APKBUILD
+++ b/community/libteam/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=libteam
-pkgver=1.23
+pkgver=1.26
pkgrel=0
pkgdesc="Library for controlling team network device"
url="http://libteam.org"
@@ -14,6 +14,7 @@ subpackages="$pkgname-dev $pkgname-doc py-$pkgname:py"
source="$pkgname-$pkgver.tar.gz::https://github.com/jpirko/$pkgname/archive/v$pkgver.tar.gz
fix-fd_set.patch
memcpy-memset-implicit-declaration.patch
+ fix-redefinition-struct-ethhdr.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -59,12 +60,15 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="f80451570e68a85983de41b0d6dcdd49 libteam-1.23.tar.gz
+md5sums="7e6c8ce5984ef3f3d77e8335804c0c6a libteam-1.26.tar.gz
ea78f0a9b84eb87747ddfbcfa582a122 fix-fd_set.patch
-fb6662bced494fd24a107e3f7f7dc5e8 memcpy-memset-implicit-declaration.patch"
-sha256sums="b9ed23da5c1a9e6bdd77aee345cce3898312fddaeeb5754dfe29a58610802a78 libteam-1.23.tar.gz
+fb6662bced494fd24a107e3f7f7dc5e8 memcpy-memset-implicit-declaration.patch
+34fb0e9679ce5d2dad48022623880c89 fix-redefinition-struct-ethhdr.patch"
+sha256sums="0fdd65e158062560b65505a5475f5524a67399ae7d2ec669b5c2793ed3f4c357 libteam-1.26.tar.gz
43bff56cfd3d293ecae58b3a77e55e7a740ddcf188d6516097fbd93b13a82ac8 fix-fd_set.patch
-a2982cbd9bce4367d1a6e20bfedcc24cab452538e2e0ec1af0d8a3515cf21077 memcpy-memset-implicit-declaration.patch"
-sha512sums="f78ceca4606b93e75fafdd97aa3cc44153fc42d31209f216c3da9c71abf38a2e4a690c71b8631ae09e02d7285d6bbd8292983fdc69eb921b0537a75558bc89f5 libteam-1.23.tar.gz
+a2982cbd9bce4367d1a6e20bfedcc24cab452538e2e0ec1af0d8a3515cf21077 memcpy-memset-implicit-declaration.patch
+b3371d5b8104091042fcc494d5af28ce59a4f89f23c7e754c30b22be2b9b9c43 fix-redefinition-struct-ethhdr.patch"
+sha512sums="4da6282af700c0ac3a76f5eaccfb750069959fe3eff116cbf08db59581e4680781b58b633816d7ea2fddfb70f1ffb0bbe3ef148ad9c61933487d176061c09919 libteam-1.26.tar.gz
83f8dd77cfed0f815bc0cb2aa4af25883a02567dbb35b59016d7f3a30f162e63155996d21216424f0ea4efa8e92f8f9526a018a892533c3c7dd7c7ba12b46a44 fix-fd_set.patch
-1279c164960b6215e9bb9f3ee161ef9ac6a38b8066d4a1031996b8067031b9b19404681ebecf3492a26b1215ec2eaaddecae3370ec25e2593dc3ca7dc5f8ead7 memcpy-memset-implicit-declaration.patch"
+1279c164960b6215e9bb9f3ee161ef9ac6a38b8066d4a1031996b8067031b9b19404681ebecf3492a26b1215ec2eaaddecae3370ec25e2593dc3ca7dc5f8ead7 memcpy-memset-implicit-declaration.patch
+db2f374018a8b60c099e5b41abf5a9d20912bddc0436788b246815459c97498fb47d237376f87a623438f2f48d486d91d65fe5b49aeeabc83cbd41bdb66d7bfc fix-redefinition-struct-ethhdr.patch"
diff --git a/community/libteam/fix-redefinition-struct-ethhdr.patch b/community/libteam/fix-redefinition-struct-ethhdr.patch
new file mode 100644
index 0000000000..c6ed2bffde
--- /dev/null
+++ b/community/libteam/fix-redefinition-struct-ethhdr.patch
@@ -0,0 +1,51 @@
+--- libteam-1.24/teamd/teamd_lw_arp_ping.c
++++ libteam-1.24.new/teamd/teamd_lw_arp_ping.c
+@@ -20,7 +20,11 @@
+
+ #include <arpa/inet.h>
+ #include <net/if_arp.h>
++#if defined(__GLIBC__)
+ #include <linux/if_ether.h>
++#else
++#include <net/ethernet.h>
++#endif
+ #include <netdb.h>
+ #include <private/misc.h>
+ #include "teamd.h"
+--- libteam-1.24/teamd/teamd_lw_nsna_ping.c
++++ libteam-1.24.new/teamd/teamd_lw_nsna_ping.c
+@@ -21,7 +21,11 @@
+ #include <netdb.h>
+ #include <netinet/ip6.h>
+ #include <netinet/icmp6.h>
++#if defined(__GLIBC__)
+ #include <linux/if_ether.h>
++#else
++#include <net/ethernet.h>
++#endif
+ #include <private/misc.h>
+ #include "teamd.h"
+ #include "teamd_link_watch.h"
+--- libteam-1.24/teamd/teamd_runner_lacp.c
++++ libteam-1.24.new/teamd/teamd_runner_lacp.c
+@@ -23,14 +23,20 @@
+ #include <unistd.h>
+ #include <limits.h>
+ #include <sys/ioctl.h>
++#if defined(__GLIBC__)
+ #include <linux/if_ether.h>
++#else
++#include <net/ethernet.h>
++#endif
+ #include <sys/socket.h>
+ #include <linux/netdevice.h>
+ #include <netinet/in.h>
+ #include <errno.h>
+ #include <team.h>
+ #include <private/misc.h>
++#if defined(__GLIBC__)
+ #include <net/ethernet.h>
++#endif
+
+ #include "teamd.h"
+ #include "teamd_config.h"