aboutsummaryrefslogtreecommitdiffstats
path: root/community/libu2f-host
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-11-10 13:17:14 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-11-10 13:21:29 +0100
commite756a421d205e651ec4325d3aa0defbd289882c1 (patch)
treef791ba129fbf63e717b99f6631084e125c4aff1c /community/libu2f-host
parentf9e819da0653c1628f30b3a4d460fccedb51000f (diff)
downloadaports-e756a421d205e651ec4325d3aa0defbd289882c1.tar.bz2
aports-e756a421d205e651ec4325d3aa0defbd289882c1.tar.xz
community/libuf2-host: move from testing
Diffstat (limited to 'community/libu2f-host')
-rw-r--r--community/libu2f-host/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/libu2f-host/APKBUILD b/community/libu2f-host/APKBUILD
new file mode 100644
index 0000000000..8c8d3675d4
--- /dev/null
+++ b/community/libu2f-host/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=libu2f-host
+pkgver=1.1.10
+pkgrel=1
+pkgdesc="Yubico Universal 2nd Factor (U2F) Host C Library"
+url="https://developers.yubico.com/libu2f-host/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="hidapi-dev json-c-dev linux-headers eudev-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="https://developers.yubico.com/libu2f-host/Releases/libu2f-host-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static \
+ --with-udevrulesdir=/usr/lib/udev/rules.d
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="91c5bf3994f1d3c9bd144f54b14b0404d839c15bef3c318619decdf1bd37214bcff33927af78a9826ff7d0bc9907c912a0e31104ae68d3a727a8436f2a1dbf7a libu2f-host-1.1.10.tar.xz"