aboutsummaryrefslogtreecommitdiffstats
path: root/community/libusrsctp
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-03 04:44:54 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-03 04:51:26 +0100
commit675c8cf37f43b8f622325167cd19d917643b9871 (patch)
treeb10a04dc39c68acd717209c3149a853c4d4c5f8d /community/libusrsctp
parentd1eb5c0b7d4b11848fe91733a1d607bd1106fff6 (diff)
downloadaports-675c8cf37f43b8f622325167cd19d917643b9871.tar.bz2
aports-675c8cf37f43b8f622325167cd19d917643b9871.tar.xz
community/libusrsctp: move from testing
Diffstat (limited to 'community/libusrsctp')
-rw-r--r--community/libusrsctp/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/libusrsctp/APKBUILD b/community/libusrsctp/APKBUILD
new file mode 100644
index 0000000000..6b4e93fecb
--- /dev/null
+++ b/community/libusrsctp/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Daniel Santana <daniel@santana.tech>
+# Maintainer: Daniel Santana <daniel@santana.tech>
+pkgname=libusrsctp
+_pkgname=usrsctp
+pkgver=0.9.3.0_git20190127
+_commit=81049b90f5703b89154a7dc06cf13f9b01811e06
+pkgrel=0
+pkgdesc="Portable SCTP userland stack"
+url="https://github.com/sctplab/usrsctp"
+arch="all"
+options="!check" # No test suite.
+license="BSD-3-Clause"
+makedepends="automake autoconf libtool"
+subpackages="$pkgname-static $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sctplab/usrsctp/archive/$_commit.tar.gz"
+builddir="$srcdir/$_pkgname-$_commit"
+
+prepare() {
+ ./bootstrap
+}
+
+build() {
+ export CFLAGS="$CFLAGS -Wno-error=address-of-packed-member -Wno-error=cpp"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="85017b9d250d7c9f86a3c65e36bd4613b7a4bd4d7c64a9b7f0022179b092b4487fea91b7ff6aee76dfdaaa9a11c3e26c92afc06d007899d44e53d182199f2338 libusrsctp-0.9.3.0_git20190127.tar.gz"