aboutsummaryrefslogtreecommitdiffstats
path: root/community/luacheck
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-03 18:31:09 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-04 00:02:06 +0200
commit4afa1e3b2d1d5a72459b615a1ce0045b0a6c221e (patch)
tree9e865e2b99aa3b86cdfa58e8b8a6bf10ac0e4b91 /community/luacheck
parenta0fca9edfaf02f91ea5362edc3525be292bf8581 (diff)
downloadaports-4afa1e3b2d1d5a72459b615a1ce0045b0a6c221e.tar.bz2
aports-4afa1e3b2d1d5a72459b615a1ce0045b0a6c221e.tar.xz
community/luacheck: upgrade to 0.22.1
Diffstat (limited to 'community/luacheck')
-rw-r--r--community/luacheck/APKBUILD8
-rw-r--r--community/luacheck/fix-caching-spec.patch40
2 files changed, 3 insertions, 45 deletions
diff --git a/community/luacheck/APKBUILD b/community/luacheck/APKBUILD
index 89d2a46874..0d58b45e7f 100644
--- a/community/luacheck/APKBUILD
+++ b/community/luacheck/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=luacheck
-pkgver=0.22.0
+pkgver=0.22.1
pkgrel=0
pkgdesc="A tool for linting and static analysis of Lua code"
url="https://github.com/mpeterv/luacheck"
@@ -9,8 +9,7 @@ arch="noarch"
license="MIT"
depends="cmd:lua lua-filesystem"
checkdepends="lua-busted"
-source="$pkgname-$pkgver.tar.gz::https://github.com/mpeterv/$pkgname/archive/$pkgver.tar.gz
- fix-caching-spec.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mpeterv/$pkgname/archive/$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
check() {
@@ -30,5 +29,4 @@ package() {
install -D -m 755 bin/$pkgname.lua "$pkgdir"/usr/bin/$pkgname
}
-sha512sums="8264000711214e8451307e7f51a45b06d2fcd5da0d3cb49952d54b07a9448431ae3fd68a8cd0a27c73c3b03e6de74e8ae786c139707e16cf938921ab582d3bfd luacheck-0.22.0.tar.gz
-43eb51299382083ad97b136c9d8d45f0422ee90a48d5d256b3b41ae98a7e6b714589a637fcef6359d54ec581229eedba86c86107866fd9baeb9a60e91145da20 fix-caching-spec.patch"
+sha512sums="b4855331e848994242191138772ce55b07ebef98b616fdeda9c1549b71f539cd7e118dd06915edcf909f08334735924aebe356d4a7dd42a5d02bd5f5dd4f021d luacheck-0.22.1.tar.gz"
diff --git a/community/luacheck/fix-caching-spec.patch b/community/luacheck/fix-caching-spec.patch
deleted file mode 100644
index 45a54f0f52..0000000000
--- a/community/luacheck/fix-caching-spec.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 0c932626b0e6829a8380d39f1cc8f936159e5e5d Mon Sep 17 00:00:00 2001
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Mon, 21 May 2018 19:14:12 +0200
-Subject: [PATCH] Fix cli caching spec to not fail when PWD contains hyphen
-
-When the current working directory (returned by `fs.get_current_dir()`)
-contains a hyphen (e.g. /home/flynn/luacheck-0.22.0), the spec
-"cli caching caches results" fails, because "-" is interpreted as
-pattern item.
-
-This commit fixes this problem by escaping "-" together with "[" and
-"]" inside the template after abspath{...} is substituted.
-
-Upstream-Issue: https://github.com/mpeterv/luacheck/pull/164
----
- spec/cli_spec.lua | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/spec/cli_spec.lua b/spec/cli_spec.lua
-index 35365dc..4749b79 100644
---- a/spec/cli_spec.lua
-+++ b/spec/cli_spec.lua
-@@ -913,7 +913,7 @@ Total: 16 warnings / 1 error in 4 files
- end
-
- -- luacheck: push no max string line length
-- local format_version, good_mtime, bad_mtime, python_mtime = cache:match(replace_abspath(([[
-+ local format_version, good_mtime, bad_mtime, python_mtime = cache:match(replace_abspath([[
-
- (%d+)
- abspath{spec/samples/good_code.lua}
-@@ -925,7 +925,7 @@ local A,B,C,D,E,F="package","561","helper","function","embrace","hepler";return
- abspath{spec/samples/python_code.lua}
- (%d+)
- return {{{"011",[3]=1,[4]=6,[5]=15,[13]="expected '=' near '__future__'"}},{},{},{}}
--]]):gsub("[%[%]]", "%%%0")))
-+]]):gsub("[%[%]%-]", "%%%0"), nil)
- -- luacheck: pop
-
- format_version = tonumber(format_version)