aboutsummaryrefslogtreecommitdiffstats
path: root/community/luacheck
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-09-30 18:03:16 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-09-30 18:03:16 +0200
commit672293f04aaf5d837203ba132d5d3a49d91f61e8 (patch)
treed23c4555ddfec5fc23f2d3e0baa743748afa0b75 /community/luacheck
parentef1c86d973076f7965df8ebd0cfb1e04d539c325 (diff)
downloadaports-672293f04aaf5d837203ba132d5d3a49d91f61e8.tar.bz2
aports-672293f04aaf5d837203ba132d5d3a49d91f61e8.tar.xz
community/luacheck: move from testing
Diffstat (limited to 'community/luacheck')
-rw-r--r--community/luacheck/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/luacheck/APKBUILD b/community/luacheck/APKBUILD
new file mode 100644
index 0000000000..c2b566ed5b
--- /dev/null
+++ b/community/luacheck/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=luacheck
+pkgver=0.20.0
+pkgrel=0
+pkgdesc="A tool for linting and static analysis of Lua code"
+url="https://github.com/mpeterv/luacheck"
+arch="noarch"
+license="MIT"
+depends="lua lua-filesystem"
+checkdepends="lua-busted"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mpeterv/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ busted .
+}
+
+package() {
+ local lver=$(lua -e 'print(_VERSION:match("[%d%.]+"))')
+ local lmod_dir="$pkgdir/usr/share/lua/$lver"
+
+ cd "$builddir"
+
+ mkdir -p "$lmod_dir"
+ cp -r src/$pkgname "$lmod_dir"/
+
+ install -D -m 755 bin/$pkgname.lua "$pkgdir"/usr/bin/$pkgname
+}
+
+sha512sums="08b1a64849b329e6ad71b1d7011fac0833de068641270adaa009e9a17139968ab73add3786a508a8787ce1fcfe1f028a35b5434221e4f1f62bea56833e0e65dd luacheck-0.20.0.tar.gz"