aboutsummaryrefslogtreecommitdiffstats
path: root/community/lxcfs
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-04-25 18:30:12 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-04-25 18:30:12 +0000
commitb7749da512823df6e2ca1c4d435b4f01f737a7bd (patch)
tree913fc63a7763d145d60f516241bff635e5fad6f4 /community/lxcfs
parent5e804cf72199c00208a0bff1b6170f8c362b41ee (diff)
downloadaports-b7749da512823df6e2ca1c4d435b4f01f737a7bd.tar.bz2
aports-b7749da512823df6e2ca1c4d435b4f01f737a7bd.tar.xz
community/lxcfs: upgrade to 3.0.0, updated APKBUILD
Diffstat (limited to 'community/lxcfs')
-rw-r--r--community/lxcfs/APKBUILD27
-rw-r--r--community/lxcfs/lxcfs-subdir.patch16
2 files changed, 19 insertions, 24 deletions
diff --git a/community/lxcfs/APKBUILD b/community/lxcfs/APKBUILD
index b7987b1c32..96b5da7221 100644
--- a/community/lxcfs/APKBUILD
+++ b/community/lxcfs/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=lxcfs
-pkgver=2.0.7
+pkgver=3.0.0
pkgrel=0
pkgdesc="FUSE filesystem for LXC"
url="https://linuxcontainers.org/lxcfs"
arch="all"
license="Apache-2.0"
depends="cgmanager shadow-uidmap uidmapshift"
-makedepends="fuse-dev linux-pam-dev linux-headers help2man"
-subpackages="$pkgname-pam $pkgname-doc"
+makedepends="fuse-dev linux-headers help2man"
+subpackages="$pkgname-doc $pkgname-openrc"
source="https://linuxcontainers.org/downloads/lxcfs/lxcfs-$pkgver.tar.gz
lxcfs.confd
lxcfs.initd
@@ -24,10 +24,17 @@ build() {
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
- make
+ --infodir=/usr/share/info \
+ --with-init-script=openrc
+ make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
@@ -39,14 +46,8 @@ package() {
"$pkgdir"/usr/share/doc/lxcfs/README.alpine
}
-pam() {
- pkgdesc="$pkgdesc (pam plugin)"
- mkdir -p "$subpkgdir"/lib
- mv "$pkgdir"/lib/security "$subpkgdir"/lib/
-}
-
-sha512sums="3bc7188eb1d688ae3e8d7bceb24be7b69aaa0791f668399dd823113082237f4fb6fc41b0a03def6db5b6354391e40eedb0189851c73cd5c269691515db230891 lxcfs-2.0.7.tar.gz
+sha512sums="e71b2d38e3893b2768721f65522680d007ae66171de42f56eddedd887bb7616c0243160cbefb1e410393ec4359b83cb738ca9ff57714006bb0c385ad478f09cf lxcfs-3.0.0.tar.gz
71df316b1aaf1a0fadc230473a66c0be4d201d706481f1042c353b79fc629e9e681ec4fe0dfb113370e00d3f40175b0d7759fdcdcce57cf1d2db585068aa6e8d lxcfs.confd
b4e3bb76f4720d74c768c44c377665ad40e92da7332efebbf9100b6164e4e81214921c751d8ecd14dcef85c22cfa79bacf7e444d8159e93c719ff81ce2e9ba1c lxcfs.initd
16c65a10b2b95a85ea21d2cb44a45c9c7faf1e22c8c438c7325be96025588834a528544598a91facc13fa93cc46f6c4534fa2ca6bb58b152a26f1ced94b18f16 README.alpine
-f7589ef65b3e01de0bb9e55c8ae06ae8124196b29b444006f3beaba308a8bebccad38e11c9c74f705dcad826aa6de0a10830053e0b025c640b7337804c48c056 lxcfs-subdir.patch"
+003702bad354bf0499449022a364a822e52e752cfb5491c9983b8f5d5160d53fbf598bdb7e7c6e7eab9544384ac79586552c3bb26463bd189e485909d884882b lxcfs-subdir.patch"
diff --git a/community/lxcfs/lxcfs-subdir.patch b/community/lxcfs/lxcfs-subdir.patch
index de53ac0f52..5469f0ecb4 100644
--- a/community/lxcfs/lxcfs-subdir.patch
+++ b/community/lxcfs/lxcfs-subdir.patch
@@ -1,6 +1,8 @@
---- lxcfs-2.0.3/Makefile.in
-+++ lxcfs-2.0.3/Makefile.in.new
-@@ -409,14 +409,14 @@
+diff --git a/Makefile.in b/Makefile.in
+index 4673b44..2a59c5e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -397,7 +397,7 @@ htmldir = @htmldir@
includedir = @includedir@
infodir = @infodir@
install_sh = @install_sh@
@@ -9,11 +11,3 @@
libexecdir = @libexecdir@
localedir = @localedir@
localstatedir = @localstatedir@
- mandir = @mandir@
- mkdir_p = @mkdir_p@
- oldincludedir = @oldincludedir@
--pamdir = @pamdir@
-+pamdir = /lib/security
- pdfdir = @pdfdir@
- prefix = @prefix@
- program_transform_name = @program_transform_name@