aboutsummaryrefslogtreecommitdiffstats
path: root/community/matchbox-keyboard/APKBUILD
diff options
context:
space:
mode:
authorDaniele Debernardi <drebrez@gmail.com>2019-10-01 23:26:57 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-06 11:25:21 +0200
commite374414df09cadc84f6006f6a8d9a2b8fe516f00 (patch)
tree12be66c227e0561cd8bf36bb449b1ea0b6e224cd /community/matchbox-keyboard/APKBUILD
parentfbc5633c1ad3c695b9af0bdea71f6e55cc62f4e0 (diff)
downloadaports-e374414df09cadc84f6006f6a8d9a2b8fe516f00.tar.bz2
aports-e374414df09cadc84f6006f6a8d9a2b8fe516f00.tar.xz
community/matchbox-keyboard: move from testing
Diffstat (limited to 'community/matchbox-keyboard/APKBUILD')
-rw-r--r--community/matchbox-keyboard/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/matchbox-keyboard/APKBUILD b/community/matchbox-keyboard/APKBUILD
new file mode 100644
index 0000000000..41d584bdab
--- /dev/null
+++ b/community/matchbox-keyboard/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Daniele Debernardi <drebrez@gmail.com>
+# Maintainer: Daniele Debernardi <drebrez@gmail.com>
+pkgname=matchbox-keyboard
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="An on screen virtual keyboard"
+url="https://www.yoctoproject.org/software-item/matchbox/"
+arch="all"
+license="GPL-2.0-only"
+makedepends="autoconf automake libtool libxft-dev libxtst-dev cairo-dev
+ gtk+3.0-dev gtk+2.0-dev libx11-dev libxrender-dev libfakekey-dev"
+source="http://git.yoctoproject.org/cgit/cgit.cgi/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2"
+options="!check" # No test suite present
+
+build() {
+ autoreconf --install
+ ./configure \
+ --prefix=/usr \
+ --enable-cairo \
+ --enable-gtk-im \
+ --enable-gtk3-im \
+ LDFLAGS="-lXrender -lX11"
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="388298370cd69155a8a11efb2198522fd2757b48861b110998eea38f31ded490d2ba0ee1a715d4a4f76a8e51411e5b3963229938d0be7d44a796e0543b8afa3e matchbox-keyboard-0.1.1.tar.bz2"