aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-applets
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 11:54:41 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-15 16:28:44 +0000
commitb7e19429f531266375e89cfd5e3a61713945f69b (patch)
tree947fe0def8a8817da5236dd0207527e7d56fa851 /community/mate-applets
parent5327edf988384ee2f8c582b8e149e488d51b9fec (diff)
downloadaports-b7e19429f531266375e89cfd5e3a61713945f69b.tar.bz2
aports-b7e19429f531266375e89cfd5e3a61713945f69b.tar.xz
community/mate-applets: bump pkgrel due to libgtop upgrade
Diffstat (limited to 'community/mate-applets')
-rw-r--r--community/mate-applets/APKBUILD37
1 files changed, 15 insertions, 22 deletions
diff --git a/community/mate-applets/APKBUILD b/community/mate-applets/APKBUILD
index 98999d9f46..2d72287899 100644
--- a/community/mate-applets/APKBUILD
+++ b/community/mate-applets/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=mate-applets
pkgver=1.18.1
-pkgrel=0
+pkgrel=1
pkgdesc="Applets for use with the MATE panel"
url="https://github.com/mate-desktop/mate-applets"
arch="all"
@@ -12,37 +12,30 @@ depends_dev=""
makedepends="$depends_dev intltool gtk+3.0-dev mate-panel-dev libwnck3-dev
mate-desktop-dev dconf-dev itstool linux-headers libxml2-dev
libxml2-utils libgtop-dev"
-install=""
subpackages="$pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
options="suid"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --sysconfdir=/etc \
- --prefix=/usr \
- --disable-stickynotes || return 1
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ --disable-stickynotes
+ make
+}
- make || return 1
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
sha512sums="3186af69f3b8b54a7f31d3c00a39ed439717200181a1e64d97b28eaf2e75b19ac79fdda44c40401687e9cece06feb1e29f52948cd73afadeb0099f64e672c036 mate-applets-1.18.1.tar.xz"