aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-backgrounds
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:09 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:47 +0100
commit514e83f4b6c65acf572205399dff1e49936cc786 (patch)
tree545bfd2d2dfe5e5aedb6ccad1dda4f8d138cbd5c /community/mate-backgrounds
parent5987ab8f905beda6af8086dc28125a530abc868b (diff)
downloadaports-514e83f4b6c65acf572205399dff1e49936cc786.tar.bz2
aports-514e83f4b6c65acf572205399dff1e49936cc786.tar.xz
main/mate-backgrounds: move to community
Diffstat (limited to 'community/mate-backgrounds')
-rw-r--r--community/mate-backgrounds/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/mate-backgrounds/APKBUILD b/community/mate-backgrounds/APKBUILD
new file mode 100644
index 0000000000..9d2232a68a
--- /dev/null
+++ b/community/mate-backgrounds/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-backgrounds
+pkgver=1.10.0
+pkgrel=0
+pkgdesc="Background images and data for MATE"
+url="https://github.com/mate-desktop/mate-backgrounds"
+arch="noarch"
+license="GPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev intltool"
+install=""
+subpackages=""
+source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="479002dcea97ade8747cd6c1ba13e06f mate-backgrounds-1.10.0.tar.xz"
+sha256sums="fc5e056d97c1b2abccf1b3f11080129f8720b5607f7ecc354e09d64b300b9794 mate-backgrounds-1.10.0.tar.xz"
+sha512sums="b69f2ad935c0759fe9616e6e46b2bbe6adfbb5c4fa35b064cef54e5d1957539a6aa5e28051f995c7d68b893b40600fedafad2929460972fd30ff78c66bdf1dea mate-backgrounds-1.10.0.tar.xz"