aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-backgrounds
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-22 14:57:31 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-25 07:11:21 +0000
commitd4258e3147482310e38d5bb74bcde220640432d1 (patch)
tree86baa1487f4d0f8e8f66c95d595ee487c00c0a10 /community/mate-backgrounds
parent839e2c19d3c3c1ea02856091f298a2c7024f73cf (diff)
downloadaports-d4258e3147482310e38d5bb74bcde220640432d1.tar.bz2
aports-d4258e3147482310e38d5bb74bcde220640432d1.tar.xz
community/mate-backgrounds: added -lang subpackage,modernize APKBUILD, added check()
Diffstat (limited to 'community/mate-backgrounds')
-rw-r--r--community/mate-backgrounds/APKBUILD36
1 files changed, 14 insertions, 22 deletions
diff --git a/community/mate-backgrounds/APKBUILD b/community/mate-backgrounds/APKBUILD
index 5fdc25dddc..83ca5963e2 100644
--- a/community/mate-backgrounds/APKBUILD
+++ b/community/mate-backgrounds/APKBUILD
@@ -2,43 +2,35 @@
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=mate-backgrounds
pkgver=1.18.0
-pkgrel=0
+pkgrel=1
pkgdesc="Background images and data for MATE"
url="https://github.com/mate-desktop/mate-backgrounds"
arch="noarch"
license="GPL2"
depends="mate-common"
-depends_dev=""
-makedepends="$depends_dev intltool"
-install=""
-subpackages=""
+makedepends="intltool"
+subpackages="$pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--sysconfdir=/etc \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
sha512sums="489ed3c57f60b471cba6afa8243cd752b534ac1881db30310b603949af7e3bfb3c9fa8d55c37942377cb36c0fc7545d940de2d03c1166e829b128e6c576f587e mate-backgrounds-1.18.0.tar.xz"