aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-panel
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:09 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:47 +0100
commit16fc94df27feef2e9064ff5a28ae6902c4cb7023 (patch)
treecd63f9dcbf6cab96745bc8183726aa9e84d9ee7b /community/mate-panel
parentd9fe9419d8e28d84721c4734e97adf2b8f0cdb4a (diff)
downloadaports-16fc94df27feef2e9064ff5a28ae6902c4cb7023.tar.bz2
aports-16fc94df27feef2e9064ff5a28ae6902c4cb7023.tar.xz
main/mate-panel: move to community
Diffstat (limited to 'community/mate-panel')
-rw-r--r--community/mate-panel/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/community/mate-panel/APKBUILD b/community/mate-panel/APKBUILD
new file mode 100644
index 0000000000..0adcaee95f
--- /dev/null
+++ b/community/mate-panel/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-panel
+pkgver=1.10.1
+pkgrel=0
+pkgdesc="The MATE panel is the area on your desktop from which you can run applications"
+url="https://github.com/mate-desktop/mate-panel"
+arch="all"
+license="GPL2"
+depends="mate-common mate-desktop"
+depends_dev=""
+makedepends="$depends_dev librsvg-dev libmateweather-dev libtool intltool itstool
+ mate-menus-dev dconf-dev libice-dev libsm-dev libcanberra-dev dbus-glib-dev
+ libwnck-dev libsoup-dev mate-desktop-dev libxml2-utils"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="2457b4db9379eae8e47d2367cee41297 mate-panel-1.10.1.tar.xz"
+sha256sums="261702b4eaf5339a55629c5f31466fb7878d5a640f80f88edde54ed1b9eba444 mate-panel-1.10.1.tar.xz"
+sha512sums="4e8e2eddf2d9ae51b2b332dc6d96130afe90a767d1aca9cbc7a60b77f1e39d233c7a1c2490f5d68f33c6bc2fc834aee9f6cfb888c0cf3ab4b7886880865c9e95 mate-panel-1.10.1.tar.xz"