aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-panel
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-22 15:01:42 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-25 07:11:21 +0000
commit21fa78d2759c2bab2e6cf4a3c8efb31d5784e4aa (patch)
tree5c5062f5d972a2ab0b261bad5894242ff725d09b /community/mate-panel
parent3331c9baa6eff565509fe3f18f22ce4e9fb91098 (diff)
downloadaports-21fa78d2759c2bab2e6cf4a3c8efb31d5784e4aa.tar.bz2
aports-21fa78d2759c2bab2e6cf4a3c8efb31d5784e4aa.tar.xz
community/mate-panel: upgrade to 1.19.3, added check(), modernize APKBUILD
Diffstat (limited to 'community/mate-panel')
-rw-r--r--community/mate-panel/APKBUILD36
1 files changed, 14 insertions, 22 deletions
diff --git a/community/mate-panel/APKBUILD b/community/mate-panel/APKBUILD
index 721714b18d..97d02cc5be 100644
--- a/community/mate-panel/APKBUILD
+++ b/community/mate-panel/APKBUILD
@@ -1,46 +1,38 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=mate-panel
-pkgver=1.18.3
+pkgver=1.19.3
pkgrel=0
pkgdesc="The MATE panel is the area on your desktop from which you can run applications"
url="https://github.com/mate-desktop/mate-panel"
arch="all"
license="GPL2"
depends="mate-common mate-desktop"
-depends_dev=""
-makedepends="$depends_dev librsvg-dev libmateweather-dev libtool intltool itstool
+makedepends="librsvg-dev libmateweather-dev libtool intltool itstool
mate-menus-dev dconf-dev libice-dev libsm-dev libcanberra-dev dbus-glib-dev
libwnck3-dev libsoup-dev mate-desktop-dev libxml2-utils"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--sysconfdir=/etc \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
-sha512sums="55eea63abe1b60a04c72a4e8158e62eab9101545343d2063bd9f98d21c5e87c283ad942bca7c160403e6ed4bf9250b850c67d4b9a6e56b602487895e2ce16ca3 mate-panel-1.18.3.tar.xz"
+sha512sums="06c2614cdd79c3b6bef7f042a636bad15b90b514d6d67f855591837371a3073852878e01b8b88043e75e0460b95daf0d76813f240693f22250281d5a9738dbad mate-panel-1.19.3.tar.xz"