aboutsummaryrefslogtreecommitdiffstats
path: root/community/mate-utils
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:10 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 11:58:47 +0100
commitca20fa8cf8d69415ba0d3d15e2cf40ac021776b8 (patch)
treea94030352e68e92110f93f74f67fdfce46ce08ae /community/mate-utils
parent3fcf5e8dcddcc1a54da0a287a256e80842a96371 (diff)
downloadaports-ca20fa8cf8d69415ba0d3d15e2cf40ac021776b8.tar.bz2
aports-ca20fa8cf8d69415ba0d3d15e2cf40ac021776b8.tar.xz
main/mate-utils: move to community
Diffstat (limited to 'community/mate-utils')
-rw-r--r--community/mate-utils/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/community/mate-utils/APKBUILD b/community/mate-utils/APKBUILD
new file mode 100644
index 0000000000..9a6e5d4edb
--- /dev/null
+++ b/community/mate-utils/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-utils
+pkgver=1.10.3
+pkgrel=0
+pkgdesc="Utilities for the MATE Desktop"
+url="https://github.com/mate-desktop/mate-utils"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev intltool glib-dev gtk+2.0-dev mate-panel-dev
+ libgtop-dev libcanberra-dev itstool libsm-dev libxml2-utils"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --prefix=/usr \
+ --enable-all-themes || return 1
+
+ make || return 1
+
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+
+md5sums="3c15f1607b9289adf3f3d9cff857b8e6 mate-utils-1.10.3.tar.xz"
+sha256sums="44acb6a7a2caa8992d0437fab74bf57d20e909ef9b780430128a2521cb61be70 mate-utils-1.10.3.tar.xz"
+sha512sums="0dcd9216dffa12a290ef39c0a121d781f9395c269d27f2cfaac728a9ffd899e65cd4d2c89213c4aa61807ea061e8ca344c6da88e3477b597084b8528dcd44d14 mate-utils-1.10.3.tar.xz"