aboutsummaryrefslogtreecommitdiffstats
path: root/community/mawk/APKBUILD
diff options
context:
space:
mode:
authorTerror <miguel.a.terron@gmail.com>2019-08-27 16:26:33 +1200
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 02:18:18 -0300
commit1a173c04b552e8d9f53619e3153020ebd99d9a36 (patch)
tree3204ca1c06d727e57cdca52a5831dda3533bd454 /community/mawk/APKBUILD
parentf57f3953e60bc69bde476f05882fb789047d367a (diff)
downloadaports-1a173c04b552e8d9f53619e3153020ebd99d9a36.tar.bz2
aports-1a173c04b552e8d9f53619e3153020ebd99d9a36.tar.xz
community/mawk: move from testing
Diffstat (limited to 'community/mawk/APKBUILD')
-rw-r--r--community/mawk/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/mawk/APKBUILD b/community/mawk/APKBUILD
new file mode 100644
index 0000000000..3add0bcbef
--- /dev/null
+++ b/community/mawk/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Miguel Terron <miguel.a.terron@gmail.com>
+# Maintainer: Miguel Terron <miguel.a.terron@gmail.com>
+pkgname=mawk
+pkgver=1.3.4
+pkgdate=20171017
+pkgrel=0
+pkgdesc="mawk is an interpreter for the AWK Programming Language"
+url="https://invisible-island.net/mawk/"
+arch="all"
+license="GPL-2"
+subpackages="$pkgname-doc"
+source="https://invisible-island.net/datafiles/release/mawk.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver-$pkgdate
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="4ed6ca0ecca12e7409d3d364b72dc6a2b411c61bf53fe8aa0b0cac65a3bdb941921c0b81d94f34c8ac9f4922c8c7566d347b5e6b5c74518ae3a88904f9e20f27 mawk.tar.gz"