aboutsummaryrefslogtreecommitdiffstats
path: root/community/mingw-w64-headers-bootstrap
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-28 19:16:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-28 19:16:14 -0300
commit9682a05265b7979cfe9132e97bdbaf2e6285aad7 (patch)
treee62878944686d91fd3a9de320197abea0bccdfe9 /community/mingw-w64-headers-bootstrap
parentf68e7b2707872b9cb48f74cebb353b2817cc345e (diff)
downloadaports-9682a05265b7979cfe9132e97bdbaf2e6285aad7.tar.bz2
aports-9682a05265b7979cfe9132e97bdbaf2e6285aad7.tar.xz
community/mingw-w64-headers-bootstrap: move from testing
Diffstat (limited to 'community/mingw-w64-headers-bootstrap')
-rw-r--r--community/mingw-w64-headers-bootstrap/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/mingw-w64-headers-bootstrap/APKBUILD b/community/mingw-w64-headers-bootstrap/APKBUILD
new file mode 100644
index 0000000000..2d0a0d9e98
--- /dev/null
+++ b/community/mingw-w64-headers-bootstrap/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=mingw-w64-headers-bootstrap
+pkgver=6.0.0
+pkgrel=0
+pkgdesc="Dummy headers for MinGW-w64 Windows"
+url="http://mingw-w64.sourceforge.net"
+arch="x86_64 x86"
+depends="!mingw-w64-winpthreads"
+license="none" # Headers with empty comments
+builddir="$srcdir/"
+
+case "$CARCH" in
+ x86_64) _target="x86_64-w64-mingw32" ;;
+ x86) _target="i686-w64-mingw32" ;;
+esac
+
+_dstring="/* Dummy header, which gets overriden, if winpthread library gets installed. */"
+
+package() {
+ mkdir -p "$pkgdir"/usr/${_target}/include
+ echo "${_dstring}" > "$pkgdir"/usr/${_target}/include/pthread_signal.h
+ echo "${_dstring}" > "$pkgdir"/usr/${_target}/include/pthread_time.h
+ echo "${_dstring}" > "$pkgdir"/usr/${_target}/include/pthread_unistd.h
+}
+