aboutsummaryrefslogtreecommitdiffstats
path: root/community/moc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-03-29 16:18:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-03-31 12:48:15 +0000
commit3df01047adec04670024c8b59ca421763e6e68a9 (patch)
treed928f149e059b400550d476007dedec20b2a6295 /community/moc
parent60a6f8ab71d314046189830d011bf6c3b78db322 (diff)
downloadaports-3df01047adec04670024c8b59ca421763e6e68a9.tar.bz2
aports-3df01047adec04670024c8b59ca421763e6e68a9.tar.xz
community/moc: move from main
Diffstat (limited to 'community/moc')
-rw-r--r--community/moc/APKBUILD70
-rw-r--r--community/moc/ffmpeg-3.patch14
2 files changed, 84 insertions, 0 deletions
diff --git a/community/moc/APKBUILD b/community/moc/APKBUILD
new file mode 100644
index 0000000000..a6ecc6fdd2
--- /dev/null
+++ b/community/moc/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
+pkgname=moc
+pkgver=2.5.0
+pkgrel=2
+pkgdesc="MOC is a console audio player"
+url="http://moc.daper.net/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="curl-dev libtool file ffmpeg-dev speex-dev alsa-lib-dev
+ libmodplug-dev faad2-dev jack-dev libmad-dev ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://ftp.daper.net/pub/soft/moc/stable/moc-${pkgver}.tar.bz2
+ ffmpeg-3.patch
+ "
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --without-rcc \
+ --with-oss \
+ --with-alsa \
+ --with-jack \
+ --with-aac \
+ --with-mp3 \
+ --with-musepack \
+ --with-vorbis \
+ --with-flac \
+ --with-wavpack \
+ --with-sndfile \
+ --with-modplug \
+ --with-ffmpeg \
+ --with-speex \
+ --with-samplerate \
+ --with-curl \
+ --disable-cache \
+ --disable-debug \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums="18e3a979b67091bfee4b62217908c473 moc-2.5.0.tar.bz2
+d43483c3c55a323dfcbdb29681879601 ffmpeg-3.patch"
+sha256sums="d29ea52240af76c4aa56fa293553da9d66675823e689249cee5f8a60657a6091 moc-2.5.0.tar.bz2
+8c8e70f6bcecff99e9bd8ada1ee4d07ad5a0b6f8f6585c7be26ff39d04ec9ec9 ffmpeg-3.patch"
+sha512sums="ca6cfd4d1d13030bd561df8ab671399a17dfb675c360ecc95a2491c6a85764d0f72259ac33665405b197f370f4fd7ef59d9a485706f8a882bff30d0fafcf252c moc-2.5.0.tar.bz2
+e060063d09263eec789e03dc0e6e1970bb3944e70e43fc2fa680b492f62c0a903eff8ef0001afc96cd668c5488afad3a863749be114165f75e7395f2e7ef78bc ffmpeg-3.patch"
diff --git a/community/moc/ffmpeg-3.patch b/community/moc/ffmpeg-3.patch
new file mode 100644
index 0000000000..f6d3225444
--- /dev/null
+++ b/community/moc/ffmpeg-3.patch
@@ -0,0 +1,14 @@
+diff --git a/decoder_plugins/ffmpeg/ffmpeg.c b/decoder_plugins/ffmpeg/ffmpeg.c
+index 206b2b1..6af6759 100644
+--- a/decoder_plugins/ffmpeg/ffmpeg.c
++++ b/decoder_plugins/ffmpeg/ffmpeg.c
+@@ -66,9 +66,6 @@ GCC_DIAG_OFF(deprecated-declarations)
+ #include <libavformat/avformat.h>
+ GCC_DIAG_ON(deprecated-declarations)
+ #include <libavutil/mathematics.h>
+-#ifdef HAVE_AV_GET_CHANNEL_LAYOUT_NB_CHANNELS
+-#include <libavutil/audioconvert.h>
+-#endif
+ #else
+ #include <ffmpeg/avformat.h>
+ #endif