aboutsummaryrefslogtreecommitdiffstats
path: root/community/moreutils/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-22 20:45:41 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-22 20:45:41 +0100
commiteef2fb960ceeb31cf966ff89f5d585da993efffb (patch)
tree0fd0b95159fb086d2c5cfe2539ca830ce1722b08 /community/moreutils/APKBUILD
parentaf6736a4b338e53e1dae2feba8d840b96f7140ad (diff)
downloadaports-eef2fb960ceeb31cf966ff89f5d585da993efffb.tar.bz2
aports-eef2fb960ceeb31cf966ff89f5d585da993efffb.tar.xz
community/moreutils: harden setting DOCBOOKXSL a bit
In the future we should remove the patch entirely.
Diffstat (limited to 'community/moreutils/APKBUILD')
-rw-r--r--community/moreutils/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/community/moreutils/APKBUILD b/community/moreutils/APKBUILD
index 95abbaffd7..513a4c60a1 100644
--- a/community/moreutils/APKBUILD
+++ b/community/moreutils/APKBUILD
@@ -15,7 +15,11 @@ source="http://ftp.de.debian.org/debian/pool/main/m/moreutils/moreutils_$pkgver.
docbook-xsl.patch"
build() {
- make
+ _docbookpath="$(echo /usr/share/xml/docbook/xsl-stylesheets-*)"
+ if [ -z "$_docbookpath" ]; then
+ error "Couldn't get $_docbookpath, you need docbook-xsl installed"
+ fi
+ make DOCBOOKXSL=$_docbookpath
}
check() {
@@ -31,4 +35,4 @@ package() {
}
sha512sums="71bd5ec4d265dff708db372189146acb067c4edaf62888755d245ccb3f4b5bb54f6c31bda68991f78c27ab231de8ea7126f947834f3604b60d7142d0357cb66b moreutils_0.63.orig.tar.xz
-6175a6ddad44d3a27305982b9637e2551b1269a84db9cd62f72970a85410970f875e44d97d96a77f1583ace4abf93455209c17bb054e38dbf11d21a95557592e docbook-xsl.patch"
+4e55b2f45443c71dcf3ff99f233119b997e52d4979985ff5269c07d98bb6ddcee74658a6006165d50757beb0054a2a2cc91d46ad60b943fbd0310b318e72de99 docbook-xsl.patch"