aboutsummaryrefslogtreecommitdiffstats
path: root/community/mtd-utils
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-04-10 16:58:02 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-19 20:59:00 +0000
commit0c08f698c1e39269da7a7959d0ede85c684a40b3 (patch)
treed0c68949e6a242701cc33e5cdbc6e2ee76ddc443 /community/mtd-utils
parentd22dacce3431039d375d1dbb9f9ad1ddbf5e4898 (diff)
downloadaports-0c08f698c1e39269da7a7959d0ede85c684a40b3.tar.bz2
aports-0c08f698c1e39269da7a7959d0ede85c684a40b3.tar.xz
community/mtd-utils: Move from testing
The mtd-utils seem use, updates and are in a good shape. Lets put them in the community repo. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'community/mtd-utils')
-rw-r--r--community/mtd-utils/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/mtd-utils/APKBUILD b/community/mtd-utils/APKBUILD
new file mode 100644
index 0000000000..00df749267
--- /dev/null
+++ b/community/mtd-utils/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
+pkgname=mtd-utils
+pkgver=2.0.0
+pkgrel=0
+pkgdesc="Utilities for handling MTD devices, and for dealing with FTL, NFTL JFFS2, etc."
+url="http://www.linux-mtd.infradead.org/"
+arch="all"
+license="GPL-2.0"
+makedepends="linux-headers lzo-dev util-linux-dev zlib-dev acl-dev"
+subpackages="$pkgname-doc"
+source="ftp://ftp.infradead.org/pub/mtd-utils/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ || return 1
+ make \
+ || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install -j1 \
+ DESTDIR="$pkgdir" \
+ || return 1
+}
+
+md5sums="70b80fccdfc1b536a91deefb91f4e2be mtd-utils-2.0.0.tar.bz2"
+sha256sums="20a377aa86af4c102e930b0d0bb9859e3a10aeb16445f6a1273989b206a717c8 mtd-utils-2.0.0.tar.bz2"
+sha512sums="52d3fab58d254fd672f53b3f1868b19ca572a8f257fc86519d7afc7979776afa37c0f21d63cc9e9cdc2e342f1cfb2d077b07847f18f6484dc660077ee347f2fb mtd-utils-2.0.0.tar.bz2"