aboutsummaryrefslogtreecommitdiffstats
path: root/community/nbd/APKBUILD
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-04 17:42:25 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 12:41:33 +0000
commitfa97962a29240c4fbabb313a9f7b3166f61a1882 (patch)
treeb05b423d004719ad0994c1521c1ee13c204d6177 /community/nbd/APKBUILD
parentbf3dc4292450ac9795bb5904877137ff21e5e088 (diff)
downloadaports-fa97962a29240c4fbabb313a9f7b3166f61a1882.tar.bz2
aports-fa97962a29240c4fbabb313a9f7b3166f61a1882.tar.xz
community/nbd: fix build (bashisms)
./configure tries to update CFLAGS/LIBS with LIBNL3_CFLAGS/LIBS using '+=': checking for LIBNL3... yes ./configure: line 14545: CFLAGS+= -I/usr/include/libnl3 : not found ./configure: line 14546: LIBS+= -lnl-genl-3 -lnl-3 : not found so later build fails without proper libnl3 flags: nbd-client.c:51:10: fatal error: netlink/netlink.h: No such file or directory #include <netlink/netlink.h> nbd-3.18 suffers from the same problem.
Diffstat (limited to 'community/nbd/APKBUILD')
-rw-r--r--community/nbd/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/nbd/APKBUILD b/community/nbd/APKBUILD
index 71a32dd176..106db87e3f 100644
--- a/community/nbd/APKBUILD
+++ b/community/nbd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=nbd
pkgver=3.17
-pkgrel=2
+pkgrel=3
pkgdesc="Tools for network block devices"
url="http://nbd.sourceforge.net"
arch="all"
@@ -17,6 +17,7 @@ builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
+ CONFIG_SHELL=/bin/bash \
./configure \
--build=$CBUILD \
--host=$CHOST \