aboutsummaryrefslogtreecommitdiffstats
path: root/community/nextcloud
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 14:25:03 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 14:51:46 +0000
commit2b2db6a7cf4c918ae49a47e9289629c7a20d839c (patch)
tree40276e4d72629d552a817c8621534fb121018a23 /community/nextcloud
parent3eb8c5cc918318648d30499c99e32af58659360e (diff)
downloadaports-2b2db6a7cf4c918ae49a47e9289629c7a20d839c.tar.bz2
aports-2b2db6a7cf4c918ae49a47e9289629c7a20d839c.tar.xz
community/nextcloud: modernize abuild
Diffstat (limited to 'community/nextcloud')
-rw-r--r--community/nextcloud/APKBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index c52aab40dc..73c138425a 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -42,22 +42,22 @@ build() {
package() {
cd "$builddir"
for dir in ${_ncconfdir} ${_ncdatadir} ${_ncwwwdir}; do
- mkdir -p "$pkgdir"$dir || return 1
+ mkdir -p "$pkgdir"$dir
done
rm -rf config data
- mv * "$pkgdir"${_ncwwwdir} || return 1
- chmod +x "$pkgdir"${_ncwwwdir}/occ || return 1
- ln -s $_ncconfdir "$pkgdir"${_ncwwwdir}/config || return 1
- install -m664 .htaccess "$pkgdir"${_ncwwwdir}/.htaccess || return 1
- install -m664 .user.ini "$pkgdir"${_ncwwwdir}/.user.ini || return 1
- install -m664 ../../${pkgname}-config.php "$pkgdir"/etc/$pkgname/config.php || return 1
- mv "$pkgdir"$_ncwwwdir/apps "$pkgdir"$_ncbasedir || return 1
- ln -s $_ncappsdir "$pkgdir"$_ncwwwdir/apps || return 1
+ mv * "$pkgdir"${_ncwwwdir}
+ chmod +x "$pkgdir"${_ncwwwdir}/occ
+ ln -s $_ncconfdir "$pkgdir"${_ncwwwdir}/config
+ install -m664 .htaccess "$pkgdir"${_ncwwwdir}/.htaccess
+ install -m664 .user.ini "$pkgdir"${_ncwwwdir}/.user.ini
+ install -m664 ../../${pkgname}-config.php "$pkgdir"/etc/$pkgname/config.php
+ mv "$pkgdir"$_ncwwwdir/apps "$pkgdir"$_ncbasedir
+ ln -s $_ncappsdir "$pkgdir"$_ncwwwdir/apps
install -m775 -g www-data -d "$pkgdir"/var/log/nextcloud
install -m644 -D "$srcdir"/nextcloud.logrotate "$pkgdir"/etc/logrotate.d/nextcloud
for dir in ${_ncconfdir} ${_ncdatadir} ${_ncappsdir}; do
- chown -R :www-data "$pkgdir"$dir || return 1
- chmod -R 770 "$pkgdir"$dir || return 1
+ chown -R :www-data "$pkgdir"$dir
+ chmod -R 770 "$pkgdir"$dir
done
}
@@ -88,15 +88,15 @@ mysql() {
}
_mv_app() {
- mkdir -p "$subpkgdir"${_ncappsdir} || return 1
+ mkdir -p "$subpkgdir"${_ncappsdir}
if [ "$1" = "pkg" ]; then
- mv "$pkgdir"${_ncappsdir}/$2 "$subpkgdir"${_ncappsdir} || return 1
+ mv "$pkgdir"${_ncappsdir}/$2 "$subpkgdir"${_ncappsdir}
elif [ "$1" = "src" ]; then
local appname="${subpkgname#$pkgname-}"
- mv "$srcdir"/$2 "$subpkgdir"${_ncappsdir}/$appname || return 1
+ mv "$srcdir"/$2 "$subpkgdir"${_ncappsdir}/$appname
fi
- chown -R :www-data "$subpkgdir"${_ncappsdir} || return 1
- chmod 770 "$subpkgdir"${_ncappsdir} || return 1
+ chown -R :www-data "$subpkgdir"${_ncappsdir}
+ chmod 770 "$subpkgdir"${_ncappsdir}
}
activity() {