aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-19 07:44:45 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-19 12:35:52 +0000
commit3f3385cfb78f7ce5fed1e51ee6ce2dfe8c2c2c55 (patch)
tree98d9ec4fb5c6ecf98782e7931078e192d281a394 /community/nodejs-current
parentb8210687d23225b9ed24a92508b4904a7d267480 (diff)
downloadaports-3f3385cfb78f7ce5fed1e51ee6ce2dfe8c2c2c55.tar.bz2
aports-3f3385cfb78f7ce5fed1e51ee6ce2dfe8c2c2c55.tar.xz
community/nodejs-current: pass -latomic depending on host_arch
Check host_arch not target_arch to decide whether -latomic is necessary.
Diffstat (limited to 'community/nodejs-current')
-rw-r--r--community/nodejs-current/APKBUILD2
-rw-r--r--community/nodejs-current/link-with-libatomic-on-mips32.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index bfd63e1d4c..f68603bd51 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -93,4 +93,4 @@ package() {
sha512sums="dd1475bd61dbc2aac563e12ced0b9423bf1f5fc421d0699526799b60254d89cbb8d01530f2f029fe146777aecadc4aa54ad62d7b33fb9195f16d8a54b1278588 node-v11.3.0.tar.gz
9145a28bc3c2ebfc5e29e7416f8387a68808607eea4d87830a14a27c80628177a02ef4ed54b0efe2384c39fedf7356d12c267567d06d53d669c55d6211bfcf8a dont-run-gyp-files-for-bundled-deps.patch
-97b4e5aabcb8c6ad93c3194826325f00d56942fbfa3934565baa51a1a047288a06066c838f34233c38a351e8d8c287601ae08b2b6b6e8dbc5aa44cbb088f24eb link-with-libatomic-on-mips32.patch"
+adba24239eb8ccb1d27664e9a8b2af0992e2b7b59d03d67bd18598bf0a266f1b572e312980face891f93fad0330488e2af1ab8f524c1798746adb64bed994831 link-with-libatomic-on-mips32.patch"
diff --git a/community/nodejs-current/link-with-libatomic-on-mips32.patch b/community/nodejs-current/link-with-libatomic-on-mips32.patch
index 62fb6fec13..1210c69f70 100644
--- a/community/nodejs-current/link-with-libatomic-on-mips32.patch
+++ b/community/nodejs-current/link-with-libatomic-on-mips32.patch
@@ -4,7 +4,7 @@
}],
],
'conditions': [
-+ [ '(target_arch=="mips" or target_arch=="mipsel") and mips_arch_variant!="r6"', {
++ [ 'host_arch=="mips" or host_arch=="mipsel"', {
+ 'link_settings': {
+ 'libraries': [ '-latomic' ],
+ },
@@ -18,7 +18,7 @@
'msvs_disabled_warnings!': [4244],
'conditions': [
-+ [ '(target_arch=="mips" or target_arch=="mipsel") and mips_arch_variant!="r6"', {
++ [ 'host_arch=="mips" or host_arch=="mipsel"', {
+ 'link_settings': {
+ 'libraries': [ '-latomic' ],
+ },