aboutsummaryrefslogtreecommitdiffstats
path: root/community/nodejs-current
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-04-29 23:42:26 +0300
committerAndy Postnikov <apostnikov@gmail.com>2020-04-29 21:06:19 +0000
commit71671d6c018461d1a88a1b3b1a3dc67881a3f8dc (patch)
tree0756b056a9ad335e85fe2c4704d99a3b061ea614 /community/nodejs-current
parent52e6fb17d318c506f076c985e163af124cf0a6f1 (diff)
downloadaports-71671d6c018461d1a88a1b3b1a3dc67881a3f8dc.tar.bz2
aports-71671d6c018461d1a88a1b3b1a3dc67881a3f8dc.tar.xz
community/nodejs-current: upgrade to 14.1.0
Diffstat (limited to 'community/nodejs-current')
-rw-r--r--community/nodejs-current/APKBUILD6
-rw-r--r--community/nodejs-current/link-with-libatomic-on-mips32.patch10
2 files changed, 8 insertions, 8 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index ac81499b56..1eae1aa2f6 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -24,7 +24,7 @@
#
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
-pkgver=14.0.0
+pkgver=14.1.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
@@ -95,8 +95,8 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="636813f73d4540d36773389bbad219046e243bb059003776b2bea65b74dc11b81ecb845e13eb5edbe2bf6492f16a91e129cdaf14771abd1a877659963a16734c node-v14.0.0.tar.gz
+sha512sums="e6483f0a9edf62a9925b7d803a18131ec1e29067479d6764bbc111df75e1e4de463342f79efc2ce285f7657360ecabe951054c196896835285fa3244648601a4 node-v14.1.0.tar.gz
940cc90aaa77a531cde13e31918a9978f9478936c3851038bcdf2869e64de03ce84dec5a46519469a90a8ba2853226825452d23d9347752abdbe04e944c083eb dont-run-gyp-files-for-bundled-deps.patch
-9f60928b53447f9590c7065bcdbdd4065d10a06e8451531615791a3bd7d14f9114807e5446e0ec00e2cb7a11a277050345e34636b199db2979d7f022b31ffde4 link-with-libatomic-on-mips32.patch
+fd7722bc6bd257e3bc684db2b12edf35fcdff1093af2b7afed3210f527d103aca1843cfc4524ea43d329c9efc8c8e9e3045590d7550b99abdef3ba84b3786984 link-with-libatomic-on-mips32.patch
ace818285ff0b868f17be64db7c7b77b314ba370fda6bac640d56bf18322a54fa015206a3e1adefa1d78ef66b597eebf10c28d6549005cd7e58f60a37c38b741 elf.patch
a4e1e7bd4f32ee30ebd319ac0c2fc751166f8fdd27f491709003dfebda51cbece9412630f0b98f0b85253ccc4f066c82997ad68abb9b87dc0b47c24d09a0643a unbundle-uv.patch"
diff --git a/community/nodejs-current/link-with-libatomic-on-mips32.patch b/community/nodejs-current/link-with-libatomic-on-mips32.patch
index 21f9960d7b..358d52d082 100644
--- a/community/nodejs-current/link-with-libatomic-on-mips32.patch
+++ b/community/nodejs-current/link-with-libatomic-on-mips32.patch
@@ -1,8 +1,8 @@
--- a/tools/v8_gypfiles/v8.gyp
+++ b/tools/v8_gypfiles/v8.gyp
-@@ -2460,6 +2460,11 @@
- }, {
- 'toolsets': ['target'],
+@@ -1201,6 +1201,11 @@
+ ['want_separate_host_toolset', {
+ 'toolsets': ['host', 'target'],
}],
+ [ 'host_arch=="mips" or host_arch=="mipsel"', {
+ 'link_settings': {
@@ -11,10 +11,10 @@
+ }],
['component=="shared_library"', {
'direct_dependent_settings': {
- 'defines': [ 'USING_V8_PLATFORM_SHARED' ],
+ 'defines': ['USING_V8_PLATFORM_SHARED'],
--- a/node.gyp
+++ b/node.gyp
-@@ -315,6 +315,11 @@
+@@ -375,6 +375,11 @@
'msvs_disabled_warnings!': [4244],
'conditions': [