aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-19 19:24:38 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-19 19:35:41 +0200
commitb4c1ca7548076441082adb693013db5ebd86c790 (patch)
treecb87b674911475fd7a81b2e8042ade8f6f009ed5 /community/notmuch
parentc76e33cf56c5f1acfd08c9a36435bc14ba4137a3 (diff)
downloadaports-b4c1ca7548076441082adb693013db5ebd86c790.tar.bz2
aports-b4c1ca7548076441082adb693013db5ebd86c790.tar.xz
community/notmuch: add subpackages for python bindings
Diffstat (limited to 'community/notmuch')
-rw-r--r--community/notmuch/APKBUILD30
1 files changed, 27 insertions, 3 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index 18005bdd01..c3a095487e 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -3,20 +3,22 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=notmuch
pkgver=0.25
-pkgrel=0
+pkgrel=1
pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/"
arch="all"
license="GPL3"
makedepends="gzip xapian-core-dev gmime-dev talloc-dev py-sphinx
- py-requests bash-completion"
+ py-requests python2-dev python3-dev bash-completion"
checkdepends="sed coreutils diffutils bash tar mdocml grep"
subpackages="
+ py2-$pkgname:py2
+ py3-$pkgname:py3
$pkgname-dev
$pkgname-doc
$pkgname-libs
+ $pkgname-emacs:emacs
$pkgname-vim:vim:noarch
- $pkgname-emacs:emacs:noarch
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
@@ -35,6 +37,10 @@ build() {
--bashcompletiondir=/usr/share/bash-completion/completions \
--zshcompletiondir=/usr/share/zsh/site-functions
make PREFIX=/usr DESTDIR="$pkgdir"
+
+ cd "$builddir"/bindings/python
+ python2 setup.py build
+ python3 setup.py build
}
package() {
@@ -103,5 +109,23 @@ zshcomp() {
"$subpkgdir"/usr/share/zsh/site-functions/
}
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"/bindings/python
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ _py python2
+}
+
+py3() {
+ _py python3
+}
+
sha512sums="5f4961818c8c0350e3fbbedd86f407a55fecf211971003a770d99ea2db89bb6b98c2294e114d6abff4d40985f506b7f4b52736a7ee5c78390eb4f2363a65c6f5 notmuch-0.25.tar.gz
430e8f02b194b0582dfd7c66a2791a0071824e1d215993a6daf89c8d2a1ee7f73a6202136b1d890fc8920a4dc309ae976da8a8b8fc8b90e489d3c04f1592876c fix-tests.patch"