aboutsummaryrefslogtreecommitdiffstats
path: root/community/notmuch
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-19 18:47:39 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-19 18:47:39 +0200
commitc83ab8bd1422b96a1491afc21c03388fb299699e (patch)
treec433f60e57b56eef264c231f2f8bdefc100545b8 /community/notmuch
parentab4f5e86e5dd92048fb536c484795cbfc88b4764 (diff)
downloadaports-c83ab8bd1422b96a1491afc21c03388fb299699e.tar.bz2
aports-c83ab8bd1422b96a1491afc21c03388fb299699e.tar.xz
community/notmuch: add vim subpackage
Diffstat (limited to 'community/notmuch')
-rw-r--r--community/notmuch/APKBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/community/notmuch/APKBUILD b/community/notmuch/APKBUILD
index 0de30e4e66..047f0b9f40 100644
--- a/community/notmuch/APKBUILD
+++ b/community/notmuch/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=notmuch
pkgver=0.24.1
-pkgrel=2
+pkgrel=3
pkgdesc="E-Mail index, search and tagging"
url="https://notmuchmail.org/"
arch="all"
@@ -14,6 +14,7 @@ subpackages="
$pkgname-dev
$pkgname-doc
$pkgname-libs
+ $pkgname-vim:vim:noarch
$pkgname-zsh-completion:zshcomp:noarch
$pkgname-bash-completion:bashcomp:noarch"
source="https://notmuchmail.org/releases/$pkgname-$pkgver.tar.gz
@@ -61,6 +62,14 @@ check() {
done
}
+vim() {
+ depends="vim notmuch"
+ pkgdesc="Vim plugins for $pkgname"
+
+ make -C "$builddir/vim" DESTDIR="$subpkgdir" \
+ prefix="/usr/share/vim/vimfiles" install
+}
+
bashcomp() {
depends=""
pkgdesc="Bash completions for $pkgname"