aboutsummaryrefslogtreecommitdiffstats
path: root/community/npapi-sdk
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-15 21:24:55 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-07-16 01:55:27 +0200
commita7c946f2fb25561976d22cbeb97eaf4db1d37019 (patch)
tree1a56864ee114e5723c0c846ff22bc4c121e93057 /community/npapi-sdk
parentc143273ac96195d2468842e2efbf35c84199f7ac (diff)
downloadaports-a7c946f2fb25561976d22cbeb97eaf4db1d37019.tar.bz2
aports-a7c946f2fb25561976d22cbeb97eaf4db1d37019.tar.xz
community/npapi-sdk: modernize APKBUILD
Diffstat (limited to 'community/npapi-sdk')
-rw-r--r--community/npapi-sdk/APKBUILD32
1 files changed, 7 insertions, 25 deletions
diff --git a/community/npapi-sdk/APKBUILD b/community/npapi-sdk/APKBUILD
index c2b9a07067..b481b81b7e 100644
--- a/community/npapi-sdk/APKBUILD
+++ b/community/npapi-sdk/APKBUILD
@@ -6,26 +6,11 @@ pkgdesc="Netscape Plugin API (NPAPI)"
url="https://bitbucket.org/mgorny/npapi-sdk"
arch="all"
license="MPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
-subpackages=""
-source="https://bitbucket.org/mgorny/npapi-sdk/downloads/npapi-sdk-$pkgver.tar.bz2"
-
-_builddir="$srcdir"/npapi-sdk-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="https://bitbucket.org/mgorny/$pkgname/downloads/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,16 +18,13 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="e81db61e206cd615cf56c4a9f301e636 npapi-sdk-0.27.2.tar.bz2"
-sha256sums="01bf34bdd0fcaa546ba3d5c96f5d91f91dd117d4ed5ffe13f56bbd5aa566ae77 npapi-sdk-0.27.2.tar.bz2"
sha512sums="827d52fbc8eb601ac0e486aed267b1ca6cb8732c92f1224f4b38e039288b77d07d47c5d4cf384a3114403b85e7f086f345912f1b20b41d27785c9bb367514842 npapi-sdk-0.27.2.tar.bz2"