aboutsummaryrefslogtreecommitdiffstats
path: root/community/nx-libs
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-05-15 19:58:23 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-15 20:00:00 +0000
commit1ee536e1ae0b08bc06af82aea150268e24414d76 (patch)
treef7e278dfa7bb244d929ea92b2ef9b987c6cda79c /community/nx-libs
parent5ee09e6cc7b2a4b26f0f037e25d6989e29ee70db (diff)
downloadaports-1ee536e1ae0b08bc06af82aea150268e24414d76.tar.bz2
aports-1ee536e1ae0b08bc06af82aea150268e24414d76.tar.xz
community/nx-libs: upgrade to 3.5.99.20
Diffstat (limited to 'community/nx-libs')
-rw-r--r--community/nx-libs/APKBUILD18
-rw-r--r--community/nx-libs/Makefile.patch11
-rw-r--r--community/nx-libs/fix-const-char.patch28
3 files changed, 10 insertions, 47 deletions
diff --git a/community/nx-libs/APKBUILD b/community/nx-libs/APKBUILD
index cd09273420..971f7d1a01 100644
--- a/community/nx-libs/APKBUILD
+++ b/community/nx-libs/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Jean-Charles de Longueville <jch@hellea.eu>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nx-libs
-pkgver=3.5.0.32
-pkgrel=1
+pkgver=3.5.99.20
+pkgrel=0
pkgdesc="NoMachine libraries (redistributed by x2go)"
url="http://x2go.org"
arch="all"
@@ -10,12 +10,15 @@ license="GPL-2.0-or-later"
depends="font-cursor-misc font-misc-misc"
makedepends="libx11-dev zlib-dev libjpeg-turbo-dev
libpng-dev libfontenc-dev linux-headers
- libxml2-dev bash automake autoconf"
-install=""
+ libxml2-dev xkbcomp-dev imake
+ bash automake autoconf libtool
+ libxext-dev libxdamage-dev libxrandr-dev
+ libxtst-dev pixman-dev gccmakedep
+ libxfont-dev libxpm-dev libxcomposite-dev
+ libxinerama-dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://code.x2go.org/releases/source/$pkgname/$pkgname-$pkgver-full.tar.gz
+source="https://github.com/ArcticaProject/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz
xf86bigfont.patch
- fix-const-char.patch
fix-musl-headers-x86.patch"
builddir="$srcdir"/$pkgname-$pkgver
@@ -36,7 +39,6 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" USRLIBDIR=/usr/lib SHLIBDIR=/usr/lib install CONFIGURE="./configure --prefix=/usr --libdir=/usr/lib --includedir=/usr/include" || return 1
}
-sha512sums="8b4a042993d45e1aee3e13e8b86f68cd5b2a8b52e9299de6129abd8e3bb89d73cf2b44b03d3c7fabbd8329abc06dc912ac95bbf936b6478b05fc202cc29a090f nx-libs-3.5.0.32-full.tar.gz
+sha512sums="4c1ababd0c3ee09bb70e68f7f8d26922b6278c5167d50eec09f8017862536e729e33a083ca6adc98ea7776ce4aaf69157a09f8cb4a94b9d2e2b02262daccbefc nx-libs-3.5.99.20.tar.gz
ee090f4e7f5933cbea6398ac461539cbdc8b7fd62f32934c78298c1e217d2a60e7f796bffdb88d36816bbfa9becd810846f5b988b5191e5a5b9da5def5d730fa xf86bigfont.patch
-3eba6a605357c0c40c1144ae296d732426c4c9c7399f7ac3d30a10eba25d7396af28af7244a55ebb27f859ce6a13af1541ec2f665991b71be9158f0cb134a6bf fix-const-char.patch
d4a881b66f0258d6d9fb947a526868944e58217d534316dfa3f0837035415467a1e8841bf6c5b821ccedcc0c9e07b425f05243ddbd22aaec7ea2165c87d9211e fix-musl-headers-x86.patch"
diff --git a/community/nx-libs/Makefile.patch b/community/nx-libs/Makefile.patch
deleted file mode 100644
index 35037d4f81..0000000000
--- a/community/nx-libs/Makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- nx-libs-3.5.0.28/Makefile
-+++ ../Makefile
-@@ -14,7 +14,7 @@
- BINDIR=$(PREFIX)/bin
- NXLIBDIR=$(PREFIX)/lib/nx
- X2GOLIBDIR=$(PREFIX)/lib/x2go
--CONFIGURE ?= ./configure
-+CONFIGURE ?= ./configure --prefix=usr
-
- SHELL:=/bin/bash
-
diff --git a/community/nx-libs/fix-const-char.patch b/community/nx-libs/fix-const-char.patch
deleted file mode 100644
index 404612cd63..0000000000
--- a/community/nx-libs/fix-const-char.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/nx-X11/lib/font/fontfile/encparse.c
-+++ b/nx-X11/lib/font/fontfile/encparse.c
-@@ -785,13 +785,13 @@
- return 0;
- }
-
--char*
-+const char*
- FontEncDirectory()
- {
-- static char* dir = NULL;
-+ static const char* dir = NULL;
-
- if(dir == NULL) {
-- char *c = getenv("FONT_ENCODINGS_DIRECTORY");
-+ const char *c = getenv("FONT_ENCODINGS_DIRECTORY");
- if(c) {
- dir = malloc(strlen(c) + 1);
- if(!dir)
-@@ -899,7 +899,7 @@
- {
- FontEncPtr encoding;
- char dir[MAXFONTFILENAMELEN], dirname[MAXFONTFILENAMELEN];
-- char *d;
-+ const char *d;
-
- if(fontFileName) {
- parseFontFileName(fontFileName, dirname, dir);