aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml-lablgtk
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-09 19:07:20 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-09 19:09:21 +0100
commiteb419ce4a54cb1665c7c1fcefe76dd32960af520 (patch)
tree2a2a38aef147c60c3cbf20583dd0ce3e2292a909 /community/ocaml-lablgtk
parentcd892ae3091445f69cdb5e7d649ad9e062eaf88b (diff)
downloadaports-eb419ce4a54cb1665c7c1fcefe76dd32960af520.tar.bz2
aports-eb419ce4a54cb1665c7c1fcefe76dd32960af520.tar.xz
community/ocaml-lablgtk: rename lablgtk to ocaml-lablgtk
Diffstat (limited to 'community/ocaml-lablgtk')
-rw-r--r--community/ocaml-lablgtk/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/ocaml-lablgtk/APKBUILD b/community/ocaml-lablgtk/APKBUILD
new file mode 100644
index 0000000000..f051827872
--- /dev/null
+++ b/community/ocaml-lablgtk/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
+# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
+pkgname=ocaml-lablgtk
+_pkgname=lablgtk
+pkgver=2.18.5
+pkgrel=4
+pkgdesc="LablGtk - an OCaml interface to GTK+ 2.x"
+url="http://lablgtk.forge.ocamlcore.org/"
+# ocaml is not built for x86, armhf
+arch="x86_64 ppc64le"
+license="LGPL-2.1-only-WITH-linking-exception"
+depends="ocaml-findlib ocaml-camlp4 ocaml"
+depends_dev="lablgtk gtk+-dev gtkspell-dev librsvg-dev gtksourceview2-dev"
+makedepends="$depends_dev ocaml-camlp4-dev"
+replaces="lablgtk"
+provides="lablgtk=$pkgver-r$pkgrel" # for backward compatibility
+subpackages="$pkgname-doc $pkgname-dev"
+source="https://forge.ocamlcore.org/frs/download.php/1627/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check textrels"
+
+build() {
+ cd "$builddir"
+
+ ./configure --prefix=/usr
+ make -j1 world
+ make -j1 opt
+ make doc
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib/ocaml/ld.conf
+}
+
+doc() {
+ default_doc
+
+ local docdir="$subpkgdir"/usr/share/doc/$pkgname/
+ mkdir -p "$docdir"
+ cp -r "$builddir"/doc/html/* "$docdir"/
+}
+
+sha512sums="7b6ba1a4dfa82cc3bbc502082ff4fccc23cc06ee4f30d01a2e423f3f99e945a4befe450d230b5aa19c5b810e9f46f2838655099d49da2db7c8a2e52eac213024 lablgtk-2.18.5.tar.gz"