aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml/compile-without-debug-info.patch
diff options
context:
space:
mode:
authorPedro Filipe <pedrofilipecerqueira@outlook.com>2019-07-16 15:19:58 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-17 06:01:13 -0300
commitf37c80a85d4121a74600479cc7064a855b83bcd6 (patch)
treeb2cec937cacdb70ded5b54c99442c1673d2b9f85 /community/ocaml/compile-without-debug-info.patch
parent2ea2cc5ac1ede223f8f226758eec4cd6efe57f42 (diff)
downloadaports-f37c80a85d4121a74600479cc7064a855b83bcd6.tar.bz2
aports-f37c80a85d4121a74600479cc7064a855b83bcd6.tar.xz
community/ocaml: update to 4.08.0
Fixes https://gitlab.alpinelinux.org/alpine/aports/issues/10583
Diffstat (limited to 'community/ocaml/compile-without-debug-info.patch')
-rw-r--r--community/ocaml/compile-without-debug-info.patch9
1 files changed, 5 insertions, 4 deletions
diff --git a/community/ocaml/compile-without-debug-info.patch b/community/ocaml/compile-without-debug-info.patch
index 06b0eda820..f2b63e4b60 100644
--- a/community/ocaml/compile-without-debug-info.patch
+++ b/community/ocaml/compile-without-debug-info.patch
@@ -2,14 +2,15 @@ Significantly decrease size of bytecode-compiled binaries (and slightly
even natives).
--- a/Makefile
+++ b/Makefile
-@@ -52,8 +52,8 @@
- CAMLYACC ?= boot/ocamlyacc
+@@ -44,8 +44,8 @@
+ CAMLRUN ?= boot/ocamlrun
include stdlib/StdlibModules
--CAMLC=$(CAMLRUN) boot/ocamlc -g -nostdlib -I boot -use-prims byterun/primitives
+-CAMLC=$(CAMLRUN) boot/ocamlc -g -nostdlib -I boot -use-prims runtime/primitives
-CAMLOPT=$(CAMLRUN) ./ocamlopt -g -nostdlib -I stdlib -I otherlibs/dynlink
-+CAMLC=$(CAMLRUN) boot/ocamlc -nostdlib -I boot -use-prims byterun/primitives
++CAMLC=$(CAMLRUN) boot/ocamlc -nostdlib -I boot -use-prims runtime/primitives
+CAMLOPT=$(CAMLRUN) ./ocamlopt -nostdlib -I stdlib -I otherlibs/dynlink
ARCHES=amd64 i386 arm arm64 power s390x
INCLUDES=-I utils -I parsing -I typing -I bytecomp -I middle_end \
-I middle_end/base_types -I asmcomp -I asmcomp/debug \
+