aboutsummaryrefslogtreecommitdiffstats
path: root/community/ocaml
diff options
context:
space:
mode:
authorTuan Hoang <tmhoang@linux.ibm.com>2019-11-22 13:08:04 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-22 14:16:59 +0000
commit6f58e167f1865920a5d21859555b905ec1b2cec3 (patch)
tree9d76f17d44ca4d3e28e174a89bf2fbf04bcce1ee /community/ocaml
parentcc60d59176ab62228f57df6cc21a66c8b9674980 (diff)
downloadaports-6f58e167f1865920a5d21859555b905ec1b2cec3.tar.bz2
aports-6f58e167f1865920a5d21859555b905ec1b2cec3.tar.xz
Revert "community/ocaml: upgraded to 4.09.0"
This reverts commit d95a53813d93148146b793532b55873416d9af63. ocaml-camlp4 latest/final version is 4.08 which does not work with ocaml 4.09. It is better if we keep ocaml 4.08 for 3.11 release and deal with ocaml-camlp4 after release. $ apk add ocaml-camlp4 ERROR: unsatisfiable constraints: ocaml-runtime-4.09.0-r0: breaks: ocaml-camlp4-4.08.1-r0[ocaml-runtime~4.08]
Diffstat (limited to 'community/ocaml')
-rw-r--r--community/ocaml/APKBUILD18
-rw-r--r--community/ocaml/compile-without-debug-info.patch13
2 files changed, 20 insertions, 11 deletions
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index 665a4d0de6..c197c5eee5 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml
-pkgver=4.09.0
-pkgrel=0
+pkgver=4.08.1
+pkgrel=1
pkgdesc="Main implementation of the Caml programming language"
url="http://ocaml.org/"
arch="aarch64 ppc64le x86_64"
@@ -18,14 +18,16 @@ subpackages="
$pkgname-compiler-libs:_compiler_libs
$pkgname-runtime
"
-source="http://caml.inria.fr/pub/distrib/ocaml-${pkgver%.*}/ocaml-$pkgver.tar.gz
+source="http://caml.inria.fr/pub/distrib/ocaml-${pkgver%.*}/$pkgname-$pkgver.tar.gz
compile-without-debug-info.patch
fix-mcontext-fields.patch
fix-segfault-in-ppc64le.patch
fix-check-parser-uptodate-or-warn.sh.patch
"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
+ cd "$builddir"
./configure \
--prefix /usr \
--bindir /usr/bin \
@@ -38,11 +40,15 @@ build() {
}
check() {
+ cd "$builddir"
+
# FIXME: there seem to be some spurious failures, ignore until fixed.
make -C testsuite all || true
}
package() {
+ cd "$builddir"
+
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
@@ -96,6 +102,8 @@ runtime() {
'*.cma' \
'VERSION' \
'stublibs' \
+ 'vmthreads/*.cmi' \
+ 'vmthreads/*.cma' \
'threads/*.cmi' \
'threads/*.cma'
do
@@ -110,8 +118,8 @@ _submv() {
rmdir -p "$pkgdir"/${path%/*} 2>/dev/null || true
}
-sha512sums="c1b666839960c157868fc32a96fe4137280a4b99464ba2c6616700b962d802ed86467ec21c341abbefdf684b8314b90fd6a5018c6de58dc29152af851eebea88 ocaml-4.09.0.tar.gz
-9421514297ae014c012f909f9b3fc08dbcac567aae9eaf2c404ed3be28c60b5cfbb55f7486185feaeb15df4f027c8754a121ee18487bc7943ec1c40b314c2e31 compile-without-debug-info.patch
+sha512sums="8239c1879926e59c3d9611ad0d97618ce21b0528f1bd59db3df9c24287ad180ffa74f34e52e1fab39e71cbf8113a9a4ee5037cc33ae64ca6a9a109fe4ada0256 ocaml-4.08.1.tar.gz
+49cbd6df3a70d00df33d34ab4508dd04d52cbc94efc6c8cac8668758e7346be3c7acedf5b8af38a0adb18c69b8d0859667b12cc11699002c048af962cf283ad2 compile-without-debug-info.patch
cd0b9a8c3dc8d952a40eb1758cc74dc388ec4bcc5fe5a25c3f073f0088bf51027b53ea1b9f6d02a84b11bd3964bec1c50b5da28caa7c1e31ec76f9930ea7d527 fix-mcontext-fields.patch
e65b647427d9c94933d5be97857daf8cdc65e25c10066740dbcbab7a4e6f8ddb2277ee7d5796abf5916e5bdd59b057de736190432c480fc8ff2a4b2a94d46eca fix-segfault-in-ppc64le.patch
b3362906c23ecdb084db7dbf18cae22f0a54ba968f1ecf9c8d13c230ca221b3f77fa820a52e091ce7b71b1cb4a91faf1346692aa6fa411bb46fca784500def25 fix-check-parser-uptodate-or-warn.sh.patch"
diff --git a/community/ocaml/compile-without-debug-info.patch b/community/ocaml/compile-without-debug-info.patch
index 05bf68e4c9..f2b63e4b60 100644
--- a/community/ocaml/compile-without-debug-info.patch
+++ b/community/ocaml/compile-without-debug-info.patch
@@ -2,14 +2,15 @@ Significantly decrease size of bytecode-compiled binaries (and slightly
even natives).
--- a/Makefile
+++ b/Makefile
-@@ -43,8 +43,8 @@
-
+@@ -44,8 +44,8 @@
+ CAMLRUN ?= boot/ocamlrun
include stdlib/StdlibModules
--CAMLC=$(BOOT_OCAMLC) -g -nostdlib -I boot -use-prims runtime/primitives
+-CAMLC=$(CAMLRUN) boot/ocamlc -g -nostdlib -I boot -use-prims runtime/primitives
-CAMLOPT=$(CAMLRUN) ./ocamlopt -g -nostdlib -I stdlib -I otherlibs/dynlink
-+CAMLC=$(BOOT_OCAMLC) -nostdlib -I boot -use-prims runtime/primitives
++CAMLC=$(CAMLRUN) boot/ocamlc -nostdlib -I boot -use-prims runtime/primitives
+CAMLOPT=$(CAMLRUN) ./ocamlopt -nostdlib -I stdlib -I otherlibs/dynlink
ARCHES=amd64 i386 arm arm64 power s390x
- INCLUDES=-I utils -I parsing -I typing -I bytecomp -I file_formats \
- -I lambda -I middle_end -I middle_end/closure \
+ INCLUDES=-I utils -I parsing -I typing -I bytecomp -I middle_end \
+ -I middle_end/base_types -I asmcomp -I asmcomp/debug \
+